CA ACF2

Expand all | Collapse all

User can't start FTP

Jump to Best Answer
  • 1.  User can't start FTP

    Posted 11-07-2017 10:09 AM

    This isn't a CA problem; I'm just out of ideas and hoping to find someone who has a good suggestion.  I have a new contractor in a TSS shop, and he's having trouble using FTP.

     

    I set him up with TSO and the BATCH facility.  He reported this error when he tried to do a batch FTP:

     

    CEE5101C During initialization, the callable service BPX1MSS failed. The system return code was 0000000156 , the reason code was 0B0C00FC . The application will be terminated..

     

    I found a web page (a CA page, actually) that said this error means there's no OMVS segment on his ID.  Dope slap—gave him a UID.  He tried it again and got the same message except now the reason code is 0B0C00FD, which it says here means he doesn't have a GID.  I set  him up with a group that has GID(1), and made it his default group.  Still the same error.

     

    Now that's just wrong.  What else does he need?  BPXMTEXT insists that reason code 0B0C00FD means he has no GID.

     

    I had him try FTP in the foreground instead of batch.  I can issue the FTP command with the IP address he specified; when he does it, he gets the same error.  I think this proves it isn't anything he's doing wrong, I just have him set up wrong.  But what could it be?  I could use some ideas.



  • 2.  Re: User can't start FTP

    Broadcom Employee
    Posted 11-07-2017 10:21 AM

    Bob,

     

    Did you also add a DFLTGRP to the acid? TSS ADD(acid) DFLTGRP(xxxxxxx) per the following Knowledge document:

     

    User Abend U4093 CEE5101C During Initialization, The Callable Service BPX1MSS Failed. 

     

    Regards,

     

    Joseph Porto - CA Level 1 



  • 3.  Re: User can't start FTP

    Posted 11-07-2017 10:38 AM

    Yeah, that's what I meant when I said I "made it his default group".  Here's an extract of his ACID:

     

    ACCESSORID = xxxxxxx   NAME       = xxxxx
    TYPE       = USER      SIZE       =     1024  BYTES             
    CREATED    = 10/12/17  13:09  LAST MOD   = 11/06/17  13:17      
    GROUPS     = GRPMOB00  OMVSGRP                                  
    LAST USED  = 11/06/17 07:17 CPU(KMC1) FAC(VTP     ) COUNT(00007)
    DFLTGRP    = OMVSGRP                                            
    -----------  SEGMENT OMVS                                       
    HOME       = /usr/cotxc01                                       
    UID        = 0000002233                                         

    ACCESSORID = OMVSGRP   NAME       = DEFAULT OMVS GROUP    
    TYPE       = GROUP     SIZE       =     1536  BYTES       
    -----------  SEGMENT OMVS                                 
    GID        = 0000000001

     

    BXPMTEXT says about 0B0C00FD "The user ID is in a group that has no GID", but it seems clear to me that he does.  I'm hoping I'll find out that once I added DFLTGRP the reason code changed, but the victim says not.



  • 4.  Re: User can't start FTP
    Best Answer

    Broadcom Employee
    Posted 11-07-2017 10:58 AM

    Bob,

     

    We have had other clients have the '0B0C00FD', but giving them a valid OMVS segment including the DFLTGRP fixed them all.

     

    Please open a ticket with support so we can run traces the following
    1. TSS ADD(acid) TRACE
    2. TSS REFRESH(acid) JOBNAME(*)
    3. TSS MODI(SECTRACE(ACT,WTL))
    4. ST SET,TYPE=OMVS,FUNC=ALL,DSN=datasetname,END (issued on the console)
    5. Bring up the region and recreate the problem.
    6. SECTRACE entries will go to syslog. OMVSTRACE entries will be written to
    the dataset.
    7. TSS MODI(SECTRACE(OFF))
    8. ST DEL,ID=xx (issued on the console)
    9. TSS REM(acid) TRACE
    10. Please send the syslog which contiains the SECTRACE entires. Also so send the dataset from step 4 which contains the OMVS traces. Please email traces as text files to pcs@ca.com with the issue number as the subject.

    The FB 133 RECL BLKSIZE 1330 dataset for the DSN= must be pre-allocated.
    Please make sure it is large enough to hold enough trace data otherwise the
    trace will stop once it is full.

     

    This will show us what TSS is passing for the OMVS segment to USS.

     

    A discussion group is not an appropriate place for your security information/setting to be shared, so please open a ticket.


    Regards,

    Joseph Porto - TOP SECRET Level 1 Support



  • 5.  Re: User can't start FTP

    Posted 11-07-2017 12:01 PM

    Oh, I paid careful attention to what info I sanitized and cited there :-).  But no problem, I opened a ticket, and thanks, Joe.  I'll get started on that trace.