Broadcom Customer Care

 View Only
Expand all | Collapse all

Bug in MegaRAID Storage Manager 17.05.06.00 Not Connecting

Jump to Best Answer
  • 1.  Bug in MegaRAID Storage Manager 17.05.06.00 Not Connecting

    Posted Jan 29, 2022 11:10 AM
    Hello,

    I would like to report a bug in the latest MSM release 17.05.06.00 (with complete install). After installing it I can no longer connect to the server:

    Servers could not be found because server may be down or server not installed in the host system

    I have verified that the MSMFramework service is running, and I have also checked with netstat that it is listening:

    TCP 0.0.0.0:3071 TS140:0 LISTENING

    If I uninstall l 17.05.06.00 and go back to the previous version (17.05.02.01) it once again starts working fine.

    Environment:
    • Fujitsu D2616 (LSI 9261-8i)
    • Windows Server 2019 (17763)
    • Latest driver 6.714.18.0 (2018)


  • 2.  RE: Bug in MegaRAID Storage Manager 17.05.06.00 Not Connecting

    Posted Jan 29, 2022 05:58 PM
    I'm having the same problem. Where can I get the previous version? I've been trying to get MSM to work on a new installation of Windows 10 after my old Windows installation got fatally damaged. This is not a remote connection - the MegaRAID is on this machine. I've tried all the troubleshooting - reinstalling after manual cleanup, checking that the driver is showing, ensuring the services are running, etc. Nothing helps.


  • 3.  RE: Bug in MegaRAID Storage Manager 17.05.06.00 Not Connecting
    Best Answer

    Posted Jan 29, 2022 09:44 PM
    I found a download for MSM 17.05.02.01 which also resolved it for me. It would be useful to have at least a few prior versions of MSM available for download.


  • 4.  RE: Bug in MegaRAID Storage Manager 17.05.06.00 Not Connecting

    Posted Jan 30, 2022 10:21 AM
    Using the old version is really not ideal - it is vulnerable to the log4j exploits - which was the whole reason for the new 17.05.06.00 update


  • 5.  RE: Bug in MegaRAID Storage Manager 17.05.06.00 Not Connecting

    Posted Jan 30, 2022 01:17 PM
    I don't do remote management so I think that's OK for me, but obviously there's a bug. It isn't just leftover files from an upgrade like that one document suggests, or downgrading wouldn't help. Besides, I wasn't upgrading. It was a new install on a new install of Windows. But yeah, I do hope they fix that.


  • 6.  RE: Bug in MegaRAID Storage Manager 17.05.06.00 Not Connecting

    Posted Feb 09, 2022 04:52 AM
    I had the same problem, but I was able to resolve it while using the latest (17.05.06.00) version.

    First, you're almost certainly installing onto a x64 version of Windows, but the MegaRAID Storage Manager is a 32-bit application, so use a 32-bit/x86 JRE.  This may not have an effect (I began with Oracle's x64 JRE, but immediately switched to the x86 AdoptOpenJDK), but it won't hurt either.

    Second, use AdoptOpenJDK as the MSM README suggests.  I used both the recommended and the latest versions-- both worked.

    Third, follow the instructions in the README for where to put the files, and be sure there are no spaces in the path as that can break the MSM start-up batch file.  Remember to set the JRE_HOME environment variable.

    Finally, the README said installing the javax.activation.jar file was not necessary for AdoptOpenJDK, but I did it anyway.

    I now have a fully functioning MSM.


  • 7.  RE: Bug in MegaRAID Storage Manager 17.05.06.00 Not Connecting

    Posted Feb 23, 2022 01:03 PM
    So, if you installed the latest version of a JRE, you kept the folder name the same, you placed it in an older version folder like in the readme?  These instructions for placing a JRE and the need (maybee?) for the JAR file are poorly written and out of date, see below from the readme.txt file included in the MSM download.

    Do I have to use that path in the readme file or can I let the current MSI download's for a JDK that include the JRE default to 'program files' directory.  Also, the current MSI files I find from the redirected site can do a system variable path within the installation.  The current MSI 's create ones called JAVA_HOME not JRE_HOME also, which I don't know if has any bearing.  I'm Java illiterate, so this has become a huge learning curve.  I'm going to keep playing with this and hopefully find and provide a solution.

    From the readme:
    "Prior to the MSM installation or Upgrade setup a JRE. Follow the below instructions to setup.
    Recommended JRE version: AdoptOpenJDK8u282-b08.

    Step 1: Download and unzip OpenJRE in your desired location ( assume: C:\jre folder)
    (i) (Not Mandatory step for AdoptOpenJDK8) Copy javax.activation.jar file to "C:\jre\jdk8u282-b08-jre\bin" folder.
    Download:https://github.com/javaee/activation/releases/tag/JAF-1_2_0

    Step2: Set OpenJRE-8.0.282.8 x86 path to System path
    (i) Go to system properties -> Advanced -> Click "Environmental Variables"
    (ii) Under "Environmental Variable" go to "system variables".
    (iii)Create JRE_HOME under "system variables" and set "C:\jre\jdk8u282-b08-jre\"


    Step 3: upgrade the MSM with new release and launch

    Notes:
    1) Download OpenJRE-8u282-b08 x86 and extract from https://adoptopenjdk.net/releases.html?variant=openjdk8&jvmVariant=hotspot
    2) Version check: Open a command prompt and check for the java version:
    %JRE_HOME%\bin\java (Version should be "1.8.0_282")"


  • 8.  RE: Bug in MegaRAID Storage Manager 17.05.06.00 Not Connecting

    Posted Feb 23, 2022 03:55 PM
    I got it to install, and work.  Here is what I found.  You HAVE to use the JRE version (jdk8u282-b08-jre), get the jar file from the linked website, place in the same directory as outlined, and create the system variable that is in the readme file.  My problem was the website in the readme no longer has it available to download that I could find.  I was able to find it at the following site:

    Red Hat build of OpenJDK Download | Red Hat Developer


  • 9.  RE: Bug in MegaRAID Storage Manager 17.05.06.00 Not Connecting

    Posted Apr 24, 2022 12:00 PM
    Thank you so much Charlie Lipperd.  I had beat my head against this issue for many, many hours.  Giving the unequivocal directions like you did (you HAVE to use...)  and supplying a link where the necessary JRE could be found was what I needed to get this working.  I hope I can buy you a beverage of your choice some day.


  • 10.  RE: Bug in MegaRAID Storage Manager 17.05.06.00 Not Connecting

    Posted Apr 29, 2022 03:30 AM

    I also want to thank you, Charlie.

    Had exactly the same problem and almost went crazy about it. With your description it worked like a charme.

    Regards, Haimo




  • 11.  RE: Bug in MegaRAID Storage Manager 17.05.06.00 Not Connecting

    Posted 6 days ago
    Yes, I want to say thanks too. I did find the JRE though at https://adoptopenjdk.net/archive.html?variant=openjdk8&jvmVariant=hotspot

    What a picky, picky system.

    Thanks again,
    Mike


  • 12.  RE: Bug in MegaRAID Storage Manager 17.05.06.00 Not Connecting

    Broadcom Employee
    Posted Jan 31, 2022 02:38 AM
    Hi @Jacob Halsey,

    Please use the following link to get support for MegaRAID and HBAs. The team will assist you further.
    https://www.broadcom.com/support/storage


    Knowledge Base
    How do I create a support ticket for LSI storage products?
    ​​​

    ------------------------------
    Regards,
    Ravi Kumar
    Customer Care Community Admin
    Broadcom Software
    ------------------------------