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Tech Tip: UMP login error :com.liferay.portal.NoSuchGroupException: No Group exists with the key 

May 26, 2017 10:19 AM

Document ID:  TEC000003832
Last Modified Date:  05/26/2017

 

 

Issue:

One of my users cannot log in in UMP:

login1.JPG 

 

The Portal log: (Nimsoft/probes/service/wasp/portal.log) is showing the following exception:

 

an-unexpected-system-error-occurred

com.liferay.portal.NoSuchGroupException: No Group exists with the key {companyId=10131, classNameId=10046, classPK=15491}

 

 

Environment:
UIM/UMP 8.x
Cause:

Although a user is able to log in into IM and Admin Console it might still be unable to log into UMP if there is any issue in the underlying 'Liferay tables' (User_ / Group_ ). In this case, the exception "com.liferay.portal.NoSuchGroupException" indicates that UMP is unable to add the liferay user (properly create the user and assign the roles in the User_table) because there is a mismatch between the User_ and Group_ tables. Specifically there is an entry for the user in the  User_  table but not in the Group_ table.

Resolution:

Check if the user is present in the following database tables

select * from user_
select * from group_

 

In this particular case

 

User was in the user_ table but not in the group_ table.
Removing the row from the user_ table and recreating the account contact resolved the issue

 

1. Verify if you have an entry for the affected user in both the Group_ table and User_ table:

 

select * from Group_

select * from User_

 

If the user is only in the User_ table then:

 

2. stop the UMP wasp 

3. execute: 

delete from User_ where userid = '<affected_user_id>' 

3. start wasp 

4. log in as admin > control panel > server administration > reindex all search indexes 

5. log out and log in as the affected <user>. 

 

After successful log-in User_ and Group_ for the affected user will be populated correctly.

Additional Information:

Related techdoc:

UMP log in error: com.liferay.portal.GroupFriendlyURLException

https://www.ca.com/us/services-support/ca-support/ca-support-online/knowledge-base-articles.TEC1513904.html

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