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Tech Tips: Simulator not found errors being constantly thrown in Registry log 

May 18, 2017 11:08 AM

Issue:

 

The following error is being thrown every 30 seconds in the registry log:

 

2017-05-08 14:59:26,002Z (09:59) [ServerRequestResponder 368] INFO com.itko.lisa.coordinator.TestRegistryImpl - getSimulator - simulator not found for tcp://xxxxxv0197.corp.com:2014/Simulator-xxxxxv0197@Default

 

When you look at the Simulator logs on 197, it is clear that the Simulator is taking traffic.

When you look at the Simulator on the Portal, there are plenty of available slots for traffic.

So why is this error being thrown?

 

Environment:

 

All supported DevTest releases and platforms

 

Cause:

 

Hung Simulator process that has been running for a while.

 

Resolution:

 

After reviewing the the simulator log running on xxxxxv0197, am seeing a reference to another Simulator running on this machine on Port 2015.

 

There is only supposed to be one Simulator on this machine.

 

Looks like there was a hung Simulator process running since April.

 

You executed the shutdown script and this one Simulator process was still running so we needed to do a kill -9 to remove it.

We then deleted all the log files and restarted the Simulator Service.

 

We are no longer seeing those error messages in the registry.log.

 

KB: TEC1452571

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