AppWorx, Dollar Universe and Sysload Community

 View Only

 migrate UVMS BV

Federico Vargiu's profile image
Federico Vargiu posted Apr 13, 2023 10:04 AM


we want to migrate some BV on another UVMS ,
and we brought them with a package deploy on the new UVMS

but job run cannot open the deployed BV on session execution graph,
we see session , task , uproc but uprocs show no color and cannot be managed (for example it is not possible to skip from session execution graph)

anyone have an idea ?

Angus Reid's profile image
Angus Reid

What are the versions and OS of UVMS that the BV is being migrated from and to? Assuming that they are the same?

Usual sequence is 

- Create package containing BV on UVMS1
- Export package to a file from UVMS1
- Import package from the file to UVMS2
- Deploy objects from the package to a node
- Open the BV on the node to see the uprcs and sessions etc

Did the actual deployment work and can the BV be opened on a node on the ne UVMS?

Federico Vargiu's profile image
Federico Vargiu


thanks for your answer,

the UVMS source is version 6.10.40  on a windows server 2019
the UVMS target  is  version 7 on a windows server 2019

the sequence I performed is the same you described but when I try to open the session execution graph  from job run section
I cannot see the uproc in event wait or manage the session to apply skip or hold to the uprocs

Angus Reid's profile image
Angus Reid

Ok so the deployment seems ok as the import process should also convert any v6 uprocs into v7 uprocs.  Is this windows or another OS?

Few things to check
 - Can any uprocs at all be run on the v7 node, even if it is is just a basic uproc that just completes with a fail or a success. Trying to prove normal node operation
- Are all the environmental elements for the new BV uprocs present on the new node such as application, domain?
- If uprocs can run ok on the v7 node then can any of the uprocs on the new BV be run individually? 

If still no joy then change the logging on the node settings to 0,TRACE,SECURITY, then save node settings and try running the new uprocs again and then check the node log for any obvious messages. 

Switch the logging back to previous after testing as TRACE will put a lot of entries into the universe log.

Federico Vargiu's profile image
Federico Vargiu

Thanks Angus for your reply ,
until yesterday I deployed the package as a template on my repository server on the new uvms,
and then I proceed with the deploy of the template on the client,
but it does not work, the job run gave me the error described ,

after many tries and I thought to your last post and I decided to try a different approch

so I deployed the "migration" package directly to client of the new UVMS and then as a template to the repository server and in this way it seems working.

I dont know the reason but know I can see the session execution graph correctly.

Thanks Angus for the time spent on this hread.

Angus Reid's profile image
Angus Reid

Only thing i can think of is maybe it is to do with either some obscure security setting or how the MU is defined or how the conversion process works from v6 to v7 (similar issue from v5 to v6 a few years back as the v6 uprocs had more bits to them and needed a conversion before they worked on v6 from v5) 

In any case glad you got it working now.