Symantec Privileged Access Management

 View Only
  • 1.  Query on cspm client

    Posted 10 days ago
    Hi Supports,

    If the cspm service seems not running on the server, is it safe to remove it?
    Is there any guideline or support matrix on which Java version compatible for 3.4.6.140?

    Regards,
    Atifah


  • 2.  RE: Query on cspm client

    Broadcom Employee
    Posted 10 days ago
    Hi Atifah, Are you talking about the cspmclientd service that is associated with an A2A client installation? Only you would know whether you need this client or not. If you don't need it, you can uninstall it, which will remove the service. And I don't understand the question about Java version compatibility. What is the context for that question?


  • 3.  RE: Query on cspm client

    Posted 9 days ago
    Hi Ralf,

    Does cspmclientd and Java comes with pam proxy?
    The reason for Java query because customer want to upgrade the Java version on their pam proxy to 7.0.351 or latest version.

    Regards,
    Atifah



  • 4.  RE: Query on cspm client

    Broadcom Employee
    Posted 9 days ago

    Hello Atifah,

    We ship openJDK with PAM Proxy.

    C:\cspm_agent\cloakware\cspmclient\jre\bin>java -version
    openjdk version "1.8.0_345"
    OpenJDK Runtime Environment (Temurin)(build 1.8.0_345-b01)
    OpenJDK Client VM (Temurin)(build 25.345-b01, mixed mode)

    C:\cspm_agent\cloakware\cspmclient\jre\bin>

    But, this is not associated to the JAVA_HOME or JRE_HOME in my environment.

    Thanks,
    Reatesh.




  • 5.  RE: Query on cspm client

    Broadcom Employee
    Posted 7 days ago
    Hi Atifah, No, the cspmclientd executable does not come with the PAM Proxy. It comes with the A2A client. Both are Java applications and have an embedded private JRE that you shouldn't try to update separately. Any other JRE installed on the same server can be updated as needed.


  • 6.  RE: Query on cspm client

    Posted 5 days ago
    Thank you, guys!