AppWorx, Dollar Universe and Sysload Community

 View Only
  • 1.  Java versions...allowed for Application Manager -- ?

    Posted Jun 23, 2022 01:07 PM
    I checked the compatibility matrix for our master Application Manager version( version 9.3.2) and it says requires
    a minimum  of Java 11.0.2 for Java 11.


    we currently have  Java 1.8.0_144   and it works fine.

    We had our infrastructure person try to install a Java 11 version on there, which was definitely higher than 11.0.2.
    After that was done - Appworx would not start up (showed up with a connection issue).

    If this new Java should have worked -- is there something else that needs to be done





  • 2.  RE: Java versions...allowed for Application Manager -- ?

    Posted Jun 24, 2022 11:02 AM
    Hi Jeff,

    Can you share what specific error was displayed when AppWorx failed to start? Was the error during startup of the server processes (RMI, agent, etc) or when you tried logging in via the client?



  • 3.  RE: Java versions...allowed for Application Manager -- ?

    Posted Jun 27, 2022 08:54 AM
    I should renote --
    after the fact I found out that we actually tried
    Java version  1.8.0_333    (ie. jre 8u333)

    Since we already were at 1.80_144  -- I would have liked to think (hope), that
    this would have worked.

    In answer to a question sent to me - about 'what specific error' --

    At startup I received an RMI error -- as if the java wouldn't make a connection
    (even though it 'seemed' that master and remote agents had connected).

    Any ideas?




    ------------------------------
    Jeff Joseph
    ------------------------------