CA Service Management

 View Only
  • 1.  CA Process Automation 4.3.04 - proxy settings

    Broadcom Employee
    Posted Sep 20, 2022 03:27 AM
    Team,
    I know there is also a CA PA community, but it seems to be dead :)

    Our customer uses CA PA 4.3.04 and now he is implementing some integration processes that need to access the internet via a proxy server and asked for help.

    I've followed some KNB docs and configured the c2osvcw.conf file.
    Using the PAM SOAP operator when a proxy server is in use.

    ...
    wrapper.java.additional.14=-Dhttp.proxyHost=<proxy hostname>
    wrapper.java.additional.15=-Dhttp.proxyPort=8080
    wrapper.java.additional.16=-DproxySet=true

    The communication is on HTTP so I didn't change anything in the OasisConfig.properties file.

    It seems that PAM doesn't communicate with the proxy at all - I've tried to check it with our network guy and he confirmed, that there is no communication between the PAM server and proxy.

    The result is that the SOAP operators end with timeout and following error message in the log:
    2022-09-19 18:37:46,624 ERROR [com.ca.pam.server.OasisGwtServlet] [96.80.50-9443-7] Error in opening connection with URL https://servicedesktest.anect.com:8443/axis/services/USD_R11_WebService?wsdl Connection timed out: connect
    java.net.ConnectException: Connection timed out: connect
    at java.net.DualStackPlainSocketImpl.connect0(Native Method)

    Any suggestions?

    Thank you,
    Jakub


  • 2.  RE: CA Process Automation 4.3.04 - proxy settings
    Best Answer

    Posted Sep 21, 2022 03:57 AM
    Edited by Jakub Kolacny Sep 21, 2022 05:09 AM
    Hi Jakub.

    I don't know, if this is valid and working and related at all. Anyway, give it a try:
    The mentioned additional java runtime settings might be for http traffic only.
    Due to your log message, I assume, that you want to access a sdm soap server through https.
    So you need to set a proxy for https traffic
    Hence:
    Instead of
    wrapper.java.additional.14=-Dhttp.proxyHost=<proxy hostname>
    wrapper.java.additional.15=-Dhttp.proxyPort=8080

    try
    wrapper.java.additional.14=-Dhttps.proxyHost=<proxy hostname>
    wrapper.java.additional.15=-Dhttps.proxyPort=8080

    Does the proxy expects any authorization?
    If so, use additionally
    wrapper.java.additional.16=-Dhttps.proxyUser=<the proxy user>
    wrapper.java.additional.17=-Dhttps.proxyPassword=<the proxy passwod>

    In my understanding these are settings for the java runtime, and as far as I am aware there isn't a java network property named "http.proxySet".
    If this setzing works, all https traffic by this java instance is using this proxy.
    If you want to exclude specific domains try to use https.nonProxyHosts.

    let me know, if this changes anything.
    Kind regards
    ...Michael


  • 3.  RE: CA Process Automation 4.3.04 - proxy settings

    Broadcom Employee
    Posted Sep 21, 2022 05:10 AM
    Hi Michael,
    you saved me again :)

    The problem was my misunderstanding of the Java settings in the c2osvcw.conf file.

    The correct setting for my case was:
    wrapper.java.additional.14=-Dhttps.proxyHost=<proxy hostname>
    wrapper.java.additional.15=-Dhttps.proxyPort=8080

    Thank you,
    Jakub