Service Virtualization

Tech Tips: Virtual Service models disappears in the Portal when restarting DevTest implemented with Docker containers 

07-07-2017 12:05 PM

Issue

The configuration of DevTest 10.1 is implemented with Docker Containers and MySQL DB. When the configuration (DevTest + DB) is restarted, the active (running) SVs no longer show in the DevTest Portal (Monitor -> Virtual Service Environments -> VSE). The Auto-Restart column shows "Enabled". 

Environment

DevTest 9.0.0 and up.

Cause

When the DB and DevTest containers were restarted, it cleared out the entire contents of vseDeploy/VSE_2013 folder. As a result, the Portal did not display any services as running.  

 

Resolution

  • Below is the  list of directories for each of these docker containers in DevTest that need to be mounted locally in your Dockers environment so that you do not lose data during a restart. ·        
  • ·         For VSE, you would want to mount the vseDeploy/VSE_2013 folder locally. 
  •         For Registry, mount the cvsMonitors folder in DEVTEST_HOME. 
  • ·         For Portal, all projects are saved in the DEVTEST_HOME/Projects. 
  •         You don't need to do anything for CAI. 
  •         Coordinator and Simulator do not contain any mars, so you don't need to do anything for those containers. 

Statistics
0 Favorited
2 Views
0 Files
0 Shares
0 Downloads

Tags and Keywords

Comments

07-27-2017 04:59 AM

Hello,

 

For registry, which data are stored in cvsMonitors folder ?

We are using DevTest for virtualisation and our cvsMonitors folder is empty.

So I'd like to understand why should I mount locally this folder.

 

Best regards.

 

Benoit

Related Entries and Links

No Related Resource entered.