DX Operational Intelligence

Tech Tip : The connector is online, but all the SCOM entities appear in CA SOI as "Unknown" 

09-14-2015 08:33 AM

SCOM 2012 r2

SCOM CONNECTOR 4.3

SOI 3.3

Catalyst Container 3.4.1

 

Q: "The connector is online, but all the SCOM entities appear in CA SOI as "Unknown"

 

A: Please check for the following message in the ifw.log(s) on the connector

   machine

 

   System.Collections.Generic.KeyNotFoundException -- The given key was not present in the dictionary" message

 

   If there is an occurrence of this message there is a known Microsoft problem in the SCOM SDK.

 

   Microsoft is aware of this issue and is working on a fix. It is recommended that you contact Microsoft Support

   to see if any pre-release versions of the fix can be made available to you.

Statistics
0 Favorited
0 Views
0 Files
0 Shares
0 Downloads

Tags and Keywords

Comments

05-24-2016 12:12 AM

Yes, my description is the same.

05-23-2016 11:51 PM

Still not working for me.

 

Though, Connector description show as:

"Catalyst 3.x connector running in Catalyst node HOSTNAME_CatalystConnector"

 

Does yours also show the same as mine?

05-23-2016 03:28 AM

The binaries was for v4.3. When you have v4.4, no new binaries are required.

05-23-2016 03:21 AM

Hi Madelaine,

 

I applied connector version 4.4 and now the "Unknown" CIs are gone.  BUT, I'm not seeing anything else either.  You mentioned that you got some new binaries from CA, what are they?... so that I can refer it back to CA support.  I have just opened a ticket with them, they have yet to respond.

05-20-2016 12:34 AM

My environment looks the same as mentioned above. I had the same issue. Logged a call with CA and got some new binaries. Applied that and it worked.

I then saw that there is a new MS SCOM connector available. Downloaded the new MS SCOM connector yesterday and installed it. Don't have the issue of 'Unknown' CIs. The new SCOM connector version is 4.4

05-19-2016 08:59 PM

It didn't work for me.  My environment:

 

SCOM 2012

SCOM CONNECTOR 4.3

SOI 4.0

Catalyst Container 3.4.1

 

Any help on this would be great.

05-18-2016 04:17 AM

The connector system for the scom connector.

 

Am 18.05.2016 um 07:20 schrieb indothai <communityadmin@communities-mail.ca.com<mailto:communityadmin@communities-mail.ca.com>>:

 

CA Communities <https://communities.ca.com/?et=watches.email.document_comment>

 

Tech Tip : The connector is online, but all the SCOM entities appear in CA SOI as "Unknown"

 

new comment by indothai<https://communities.ca.com/people/indothai?et=watches.email.document_comment> View all comments on this document<https://communities.ca.com/docs/DOC-231160421?et=watches.email.document_comment#comment-233937845>

05-18-2016 01:01 AM

Hi Andre,

 

I'm also having the same problem.  Which system did you restart?

09-14-2015 06:25 PM

Got this error today, we have restarted the whole system that fixed the problem for us. It was a new installation Catalyst based SCOM Connector.

(same versions as mentioned by paul)

regards

 

André

Related Entries and Links

No Related Resource entered.