Clarity Configuration Automation

Tech Tip: CCA Agent cannot install libstdc++ on 64bit linux system 

08-14-2015 04:38 AM

Please check first the agent is supported.

 

These packages are required for the CCA Agent to run:

 

compat-libstdc++-33-3.2.3-39.el6.i686

compat-libstdc++-33-3.2.3-39.el6.x86_64

libstdc++-4.4.7-3.el6.x86_64

libstdc++-4.4.7-3.el6.i686

 

You should find the agent installs after these are installed.

Statistics
0 Favorited
0 Views
0 Files
0 Shares
0 Downloads

Tags and Keywords

Comments

Hi!

Please let me know if this reccomendation should be applied in order to update my own installation script.

 

regards

Leandro Cianconi

03-31-2016 09:35 AM

Hi Adnan

I would suggest that the ccaagent script on line , na linha if [ -x  /etc/rc.d/init.d/functions ] It should be changed to

if [ -f  /etc/rc.d/init.d/functions ] because in RED HAT 6.x version, the file functions HAD the permissions Changed

for read only  and if redhat not have lib redhat-lsb-core-4.0-7.el6.x86_64 installed (/lib/lsb/init-functions)installed the error occurs:

/etc/init.d/ccaagent: line 11: /lib/lsb/init-functions: No such file or directory

 

thx

Carlos Jessé

 

03-30-2016 03:59 PM

Yes, but thats is pretty much for overall system as the LSB is intended increase compatibility among Linux distributions.  It's becoming a standard; not necessarily just for CCA Agent, but many applications in general

03-30-2016 03:24 PM

Hi Adnan

I have a cliente that says that LIB redhat-lsb is required at startup time of the CCA agent , is this true?

Is this LIB needed too?

 

This Linux is RedHat 6;5 !

thx

 

 

 

Related Entries and Links

No Related Resource entered.