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Tech Tips: Connection to the registry database cannot be established. Please make sure the database is running and the credentials used to connect to database is valid. If you continue, data will not 

Nov 21, 2017 02:21 PM

This error is due to not having connectivity to the machine and port of where the database is running.

 

All DevTest ports must be bi-directional including ones to the database.

 

To troubleshoot, do a telnet from the Workstation machine to the machine and port the database is running on and make sure you get a good connection.

 

You will also have to open Workstation port 2008 to accept communication from the database machine.

 

Once the firewall is open, this should resolve the issue.

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Oct 08, 2018 03:44 PM

no ,it is MS SQL Server.

 

This is what i got from the case I opened. Instead of communicating to DB via Registry, Workstation gets the connection details and credentials(in my case integrated Security = true) from registry properties file from the server and uses it to connect to DB directly on the local machine. so in my case it will use windows authentication.

 

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Issue

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When using the Workstation, some users are getting:

Error: Connection to the registry database cannot be established. Please make sure the database is running and the credentials used to connect to database is valid. If you continue, data will not be saved to the database. Do you want to continue?

 

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Cause

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You are using SQL Server with Windows Authentication.

The connection string contains integratedSecurity=true

 

The users without database login access are receiving the message.

 

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Solution

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All DevTest components, including the Workstation, need direct access to the Registry database.

 

Using normal database login (non Windows Authentication), a user name and password is supplied. This user/password is passed to all DevTest components and login is allowed.

With Windows Authentication, the credentials of the user logged into Windows is used for the individual DevTest components.

 

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Oct 08, 2018 03:32 PM

Is your database MySQL by chance?

Oct 01, 2018 04:41 PM

Resolution did not work in my case. I had to give Registry DB to the user to get it resolved which should not be the case. Raising a ticket also.

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