Service Virtualization

Expand all | Collapse all

Getting error while setting up the Agent for IBM WebSphere server

  • 1.  Getting error while setting up the Agent for IBM WebSphere server

    Posted 11 days ago
    Hello,

    While setting up the agent in IBM WebSphere i am getting below error message in agent log.

    Error Meassage :
    Starting Agent (10.5.0.507)...
    Broker Connection: tcp:/abc.com:2009
    Stats Gathering Thread] UNCAUGHT THROWABLE
    java.lang.NoClassDefFoundError: com.itko.lisa.remote.plumbing.JMSAgentClient (initialization failure)
            at java.lang.J9VMInternals.initializationAlreadyFailed(J9VMInternals.java:96)
            at com.itko.lisa.remote.stats.AgentStats$1$1.run(AgentStats.java:74)
            at java.security.AccessController.doPrivileged(AccessController.java:696)
            at com.itko.lisa.remote.stats.AgentStats$1.run(AgentStats.java:60)
    Caused by: java.lang.IllegalArgumentException: hostname can't be null
            at java.net.InetSocketAddress.checkHost(InetSocketAddress.java:160)
            at java.net.InetSocketAddress.<init>(InetSocketAddress.java:227)
            at com.itko.lisa.remote.plumbing.JMSAgentClient.<clinit>(JMSAgentClient.java:79)
            at com.itko.lisa.remote.Agent.start(Agent.java:653)
            at com.itko.lisa.remote.Agent2Transformer.transform(Agent2.java:509)
            at sun.instrument.TransformerManager.transform(TransformerManager.java:200)
            at sun.instrument.InstrumentationImpl.transform(InstrumentationImpl.java:450)
            at java.lang.VMAccess.findClassOrNull(Native Method)
            at java.lang.VMAccess.findClassOrNullHelper(VMAccess.java:55)
            at com.ibm.oti.vm.BootstrapClassLoader.loadClass(BootstrapClassLoader.java:81)




    I have fallowed below steps :
    Administrative Console
    In this procedure, you use the web-based Administrative console to specify the agent parameters string.
    Follow these steps:
    • Go to the Administrative console.
    • Navigate to your application server.
    • Expand 
      Java and Process Management
       and click 
      Process definition
       on the Configuration tab.
    • Click 
      Java Virtual Machine
       under 
      Additional Properties
      .
    • Specify the agent parameters string in the 
      Generic JVM arguments
       field. If you paste in the string, be sure to check whether the string has been truncated.

      i have given JVM argument like this : -javaagent:/home/itko/agent/InsightAgent.jar=name=was,url=tcp://abc.com:2009  and copied two jar( InsightAgent and Lisaagent ) files in the home directory. 



      Thanks,
      Bhairava


  • 2.  RE: Getting error while setting up the Agent for IBM WebSphere server

    Posted 11 days ago
    HI Bhairava
     
    Please try the URL like this:

     -javaagent:"C:\Program Files\CA\DevTest\agent\InsightAgent.jar"=url=tcp://localhost:2009,name=IAMCL   


    regards
    Sankar Natarajan





  • 3.  RE: Getting error while setting up the Agent for IBM WebSphere server

    Posted 11 days ago
    Caused by: java.lang.IllegalArgumentException: hostname can't be null
    Hi Bhairava,

    Looking at the stack trace it looks like you have an invalid argument in the configuration.

    Caused by: java.lang.IllegalArgumentException: hostname can't be null

    Double-check the configuration.

    Regards,
    Brad


  • 4.  RE: Getting error while setting up the Agent for IBM WebSphere server

    Posted 11 days ago
    Hi Bhairava,

    I agree with Bradley, check the arguments in the configuration as hostname null is mentioned in logs.

    Thanks


    ------------------------------
    Regards,
    Vaibhav Jain
    Capgemini
    ------------------------------