Clarity

 View Only
  • 1.  Previous attribute value in Start condition builder

    Posted Feb 20, 2013 07:23 AM
      |   view attached
    Hi All,

    Here is what I'm trying , one process should start when task start date is changed. I was trying to give the condition that "current value is not equal to previous value" for start date on update event.
    I have done this before, it is very simple yet it somehow doesn't populate. I'm I missing something here? It is very simple and I did it many times (in v12 though) .

    The values are not populating. Attached a screenshot regarding the same.

    [UPDATE] Actually, I gave the primary object as "Project" because I want to send a notification to some particular user/group etc. when there is a change in schedule of a project. If I change the primary object to "Task" the dropdown in previous attribute gets populated and I'm able to give the proper condition. But, I just want to send only one notification If the project schedule is changed :blink: so the primary object cannot be task else If 4 task's start dates are changed then it would trigger 4 notifications to that user/group :wacko:

    [ANOTHER UPDATE] Will the checkbox "Do not start a new process if one is already running" do for me in this case?

    Need experts advice

    Thanks in advance,
    Ritesh Kumar


  • 2.  RE: Previous attribute value in Start condition builder

    Posted Feb 25, 2013 01:43 PM
    Hi All,

    Any ideas here for Ritesh?

    Thanks!
    Chris


  • 3.  RE: Previous attribute value in Start condition builder

    Posted Mar 09, 2013 01:05 PM
    Hi Ritesh,

    Is the attribute configured for Audit?


  • 4.  RE: Previous attribute value in Start condition builder

    Posted Mar 11, 2013 01:00 AM
    Hi Adi,

    Thanks for the response.
    Yes, Task object's Start and End date are configured for Audit. Something wrong (dependency) with the audit of an attribute and it's presence in start condition of a process?

    Regards,
    Ritesh