DX Infrastructure Manager

Expand all | Collapse all

NAS 9.30 on UIM 9.0.2 is supported

Jump to Best Answer
  • 1.  NAS 9.30 on UIM 9.0.2 is supported

    Posted 05-29-2020 03:38 PM
    Hi all,

    I can see the alarms between the Portal and NAS are not in sync. most the time the alarm is gone on the NAS (IM) but still on the Portal, since is on the Portal, CA SOI still show the alarm as active.

    If you go to the probe, that is generated the alarm the alarm is GONE and also GONE from NAS (IM) but when you go to the Portal still there.

    I did many tests and able to see the clear on the IM just pass by NAS not on the EMS,

    \par May 29 16:08:30:946 [140170131875584] 3 nas: \tab ndbOracleExecuteInternal -> INSERT INTO NAS_TRANSACTION_LOG (type,time,nimid,nimts,"level",severity,message,sid,subsys,source,hostname,prid,robot,hub,nas,domain,origin,suppcount,acknowledged_by,tz_offset,visible,i18n_token,i18n_dsize,i18n_data) VALUES (4,to_timestamp('2020-05-29 16:08:27','RRRR-MM-DD HH24:MI:SS'),'\cf1\b QP14900297-00447\cf0\b0 ',to_timestamp('2020-05-19 12:21:27','RRRR-MM-DD HH24:MI:SS'),0,'clear','Robot vmsnmprubao is inactive','1.2.2','Robot','192.168.0.22','vmsnmprubao','hub','vmsnmprubao','HUBprimario','HUBprimario','uimORACLEcentos7_domain','HUBprimario',9507,'administrator',10800,1,'as#hub.robot.alive.1',32,'cm9ib3QANwAxMgB2bXNubXBydWJhbwA=') . timing: 2. type: 4
    \par May 29 16:08:30:946 [140170131875584] 5 nas: ndbOCIPrep - enter
    \par May 29 16:08:30:946 [140170131875584] 5 nas: ndbOCIPrep - first pass OK
    \par May 29 16:08:30:946 [140170131875584] 5 nas: ndbOCIPrep - second pass OK, sql[DELETE FROM NAS_ALARMS WHERE nimid='\cf1\b QP14900297-00447\cf0\b0 '], len; 53
    \par May 29 16:08:30:946 [140170131875584] 5 nas: ndbOCIPrep - pass 3, getting ubstatement type: 3
    \par May 29 16:08:30:946 [140170131875584] 3 nas: ndbOracleExecuteInternal - iPrep: 0, ubStmtType: 3 [DELETE FROM NAS_ALARMS WHERE nimid='\cf1\b QP14900297-00447\cf0\b0 ']
    \par May 29 16:08:30:950 [140170131875584] 3 nas: ndbOracleExecuteInternal - EXEC OK
    \par May 29 16:08:30:950 [140170131875584] 5 nas: ndbOracleExecuteInternal - else, committing
    \par May 29 16:08:30:951 [140170131875584] 3 nas: \tab ndbOracleExecuteInternal -> DELETE FROM NAS_ALARMS WHERE nimid='\cf1\b QP14900297-00447\cf0\b0 ' . timing: 5. type: 3
    \par May 29 16:08:30:951 [140170131875584] 2 nas: NiS bridge: NA UPDATED CLOSE: nimid='\cf1\b QP14900297-00447\cf0\b0 ' rc: 0 took 5ms
    \par May 29 16:08:30:951 [140170131875584] 5 nas: SqliteExecuteCallback: sqlite3_finalize returned:0
    \par May 29 16:08:31:003 [140170131875584] 5 nas: SqliteExecuteCallback: sqlite3_finalize returned:0
    \par May 29 16:08:30:943 [140170131875584] 5 nas: ndbOCIPrep - pass 3, getting ubstatement type: 4
    \par May 29 16:08:30:943 [140170131875584] 3 nas: ndbOracleExecuteInternal - iPrep: 0, ubStmtType: 4 [INSERT INTO NAS_TRANSACTION_LOG (type,time,nimid,nimts,"level",severity,message,sid,subsys,source,hostname,prid,robot,hub,nas,domain,origin,suppcount,acknowledged_by,tz_offset,visible,i18n_token,i18n_dsize,i18n_data) VALUES (4,to_timestamp('2020-05-29 16:08:27','RRRR-MM-DD HH24:MI:SS'),'\cf1\b QP14900297-00447\cf0\b0 ',to_timestamp('2020-05-19 12:21:27','RRRR-MM-DD HH24:MI:SS'),0,'clear','Robot vmsnmprubao is

    ###################

    The environment is UIM 9.0.2 but has nas 9.20T2.

    My question is can I use NAS 9.30 on UIM 9.0.2 until I not able to upgrade, I still need the maintenance window for middle of June 2020.

    Thank you 

    Rubens Massini





  • 2.  RE: NAS 9.30 on UIM 9.0.2 is supported
    Best Answer

    Posted 05-30-2020 08:30 PM
    The portal gets alarms from EMS. If the nas shows the alarms right and the portal doesn't then the problem will be with EMS. Try restarting just the ems probe and see what happens.

    And since no one from support has chime in, I'd say that you'll likely experience issues with running 9.30 nas on a 9.0 system - maybe not but probably.



  • 3.  RE: NAS 9.30 on UIM 9.0.2 is supported

    Posted 05-31-2020 09:05 AM
    Hi Garin thank you for the reply,

    I was thinking the EMS was the probe, but I did few test on the clean up message and the EMS never show any message on the clean up, I guess not sure the clean up alarm is just NAS.
    \par May 29 16:08:30:951 [140170131875584] 3 nas: \tab ndbOracleExecuteInternal -> DELETE FROM NAS_ALARMS WHERE nimid='\cf1\b QP14900297-00447\cf0\b0 ' . timing: 5. type: 3

    Regards EMS I already stop stated many times and also increase the memory but still same issue.

    Customer is using EMS 10.20 I will apply EMS 10.22 and will check.

    Regards the NAS customer is running 9.20T2 on the 9.0.2 maybe this is already the problem.

    Thanks again

    Rubens.