ESP dSeries Workload Automation

Expand all | Collapse all

can't reply to thread / question

  • 1.  can't reply to thread / question

    Posted 11-30-2020 10:27 AM

    SQLException: Output parameters have not yet been processed. Call getMoreResults().

    https://community.broadcom.com/enterprisesoftware/communities/community-home/digestviewer/viewquestion?ContributedContentKey=6d85db3f-c2f0-48ea-a6f2-aa65aaaf9417&CommunityKey=01f9af04-bcec-4c48-8697-829ab833175a&tab=digestviewer

    @Nitin Pande

    Hi Nitin,
    Thanks for your reply to my question in the link above.  I'm sorry, I can't find any way to reply to your answer in the above question, so I'm opening a thread.  I tried what you said to do in this but it still doesn't work.
    Here is what I changed in the agentparam.txt file like it says in the documentation (the link you provided, thanks):

    jdbc.drivers=net.sourceforge.jtds.jdbc.Driver:sun.jdbc.odbc.JdbcOdbcDriver:com.microsoft.sqlserver.jdbc.SQLServerDriver

    Thank you for your help,
    Des



  • 2.  RE: can't reply to thread / question

    Broadcom Employee
    Posted 11-30-2020 12:14 PM
    Hi,
    Yes, I didn't see the reply button in last thread as well.  I noticed the initial error "Java Runtime Environment (JRE) version 1.7 is not supported by this driver. "
    What version of agent are you using?  If the agent is on JRE 1.7 then you are on old 11.3 release.  Most new JDBC will not work with JRE 7, they are released for JRE 8 (1.8).  You will need to upgrade to 11.4 or 11.5.

    Also try this:
    jdbc.drivers=com.microsoft.sqlserver.jdbc.SQLServerDriver
    Remove the other two.  Also, make sure to remove the jTDS jdbc jar in the jars/ext directory.


    HTH,
    Nitin Pande

    ------------------------------
    Support
    Broadcom
    Toronto
    ------------------------------