DX NetOps

 View Only
  • 1.  QoS KPI retrieval (filtered)

    Posted Nov 26, 2021 12:51 PM
    Hello,

    I need to collect QoS Classmap for:
    1. A small group of devices
    2. Only a couple of interfaces ( 1 to 3) from each device, and 2 different QoS classes.

    What is the best way you see to do this retrieval?

    I ask because the QoS MF is associated with the device, not the interfaces.. so I can't do a small group of interfaces from which I can get the QoS information.. Can I?

    Thank you.

    BR
    Bruno Sousa



  • 2.  RE: QoS KPI retrieval (filtered)

    Broadcom Employee
    Posted Nov 26, 2021 03:29 PM
    You can start with the Group Rule:

    You can add more filters...

    ------------------------------
    Thank you,
    Carlos A. Radice
    Sr Support Engineer
    Broadcom Software
    ------------------------------



  • 3.  RE: QoS KPI retrieval (filtered)

    Posted Nov 29, 2021 09:29 AM

    I see some challenges with the aproach...

    1. I can't put that kind of filter in the "Monitoring Profile".. can only filter by name and description of the component itself. Not by the device it is on, for example..
    2. I can only present the QoS components in a dashboard from a group of devices.. no views apparently that take a group of QoS components and do the visualization.. Am I missing something.

    Any comment?

    Thank you.

    BR
    Bruno Sousa


  • 4.  RE: QoS KPI retrieval (filtered)
    Best Answer

    Broadcom Employee
    Posted Nov 29, 2021 10:27 AM
    You are correct, you can only filter at the MP level using Name and Description of the component.

    The device filtering is done by the collection you have associated to the MP.

    But there is no additional filtering for the interface name.  Unless the interface name is in the Name or Desc of the QOS component, then you can do filtering based on interface name in the QOS component filters.

    You should be able to have a group of a specific QOS type (classmap or qosred or...) components and a view that shows that QOS MF and see data for those qos components.


  • 5.  RE: QoS KPI retrieval (filtered)

    Posted Nov 29, 2021 10:46 AM
    Edited by Bruno Sousa Nov 29, 2021 01:02 PM
    Jeffrey,

    What I've done:
    1, Created a group and added manually some QoS Classmap device components
    2. Applied this group with the device components to several dynamic / custom views: table, IM Card View, Dynamic trend view, etc. (none of them worked..)
    3. When I do the same procedure with but with a group of devices (making sure that the device components are also inherited) the views work (this way I can't filter de QoS Classmap components that I want to put in the dashboard though... I have to put them all... or at least all that exist in the device)

    Am I missing something?

    What I needed:
    1. A group with "QoS classmap" device components filtered by naming "XPTO".
    2. Apply this group to a view and see the graphics only for these specific QoS components

    Thank you.

    BR
    Bruno Sousa


  • 6.  RE: QoS KPI retrieval (filtered)

    Broadcom Employee
    Posted Nov 29, 2021 01:37 PM
    That should work with a group of QOS classmap components.
    Can you edit say a table or trend view?  Take screenshots of the entire view config.

    Can you also goto Inventory->Device Components, change group context to your QOS classmap components.  Does it show just the QOS classmap components you added to the group??

    After seeing the view config, I will probably suggest opening a support ticket.  Either the group ETL table is not getting updated in the DA, or the group memberships are not being synced to DA.  They'll be able to check the various causes, and if need be, run through a Generate URL debug step to check what PC/DA is doing during the view load.


  • 7.  RE: QoS KPI retrieval (filtered)

    Posted Nov 30, 2021 11:58 AM
    Jeffrey,

    With the tip you gave to see the inventory->device components and filter, I could see that there was a problem with this particular QoS items and were marked as retired.

    After doing some changes I was able to put them online and I was able to use the components in the dashboard as pretended.

    Thank you for the help!

    BR
    Bruno Sousa