Service Virtualization

Expand all | Collapse all

Unable to listen for requests on address/port

Jump to Best Answer
  • 1.  Unable to listen for requests on address/port

    Posted 21 days ago
    Hi ,

    I am having strange issue .. while executing VSM in ITR mode I am getting below issue, even I did not deployed any service on that port.
    however, If I change port number model is running in ITR mode. can some one provide solution.

    Error:
    Unable to listen for requests on address/port 9064. It is either currently in use by another process or is not allowed by the operating system.
    ----------------------------------------------------------------------------
    | Trapped Exception: Address already in use: bind
    | Trapped Message: java.net.BindException: Address already in use: bind
    ----------------------------------------------------------------------------

    service was running successfully on port (9064) from last three months and I don't want to change port number for this service.

    Thanks,
    Venu


  • 2.  RE: Unable to listen for requests on address/port

    Posted 20 days ago

    Hi,

     

    Could be a ghost process keeping that port bound? Or some other new program that was just introduced and coincidentally also uses that port?

    Either way, if the port is in use than you should be able to find out from where using the command: netstat -a -b

    And then there is always this problem solver which is around since the dawn of the personal computer: have you tried turning it off and on again?

     

    Cheers,

    Danny

     

    ::DISCLAIMER::

    The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only. E-mail transmission is not guaranteed to be secure or error-free as information could be intercepted, corrupted, lost, destroyed, arrive late or incomplete, or may contain viruses in transmission. The e mail and its contents (with or without referred errors) shall therefore not attach any liability on the originator or HCL or its affiliates. Views or opinions, if any, presented in this email are solely those of the author and may not necessarily reflect the views or opinions of HCL or its affiliates. Any form of reproduction, dissemination, copying, disclosure, modification, distribution and / or publication of this message without the prior written consent of authorized representative of HCL is strictly prohibited. If you have received this email in error please delete it and notify the sender immediately. Before opening any email and/or attachments, please check them for viruses and other defects.






  • 3.  RE: Unable to listen for requests on address/port

    Posted 20 days ago
    Hi Venu,
         Based on the error, it looks like port (9064) is already used on your local machine. As you are running VSM in ITR, service will try to listen on localhost with port 9064. Please check the port usage using netstat command from command prompt and stop the process which is running or give the different port number and test it

    Thanks
    Srikanth


  • 4.  RE: Unable to listen for requests on address/port
    Best Answer

    Posted 20 days ago
    Hi Venu,

    It might be because some other process might be running on the port already. 

    Check the port usage from cmd (in case of windows) with below command:

    netstat -ano | findStr "9064"  --> If any process is found, you can kill it using below command:

    taskkill /F /PID <<ProcessID>>

    Thanks.


    ------------------------------
    Regards,
    Vaibhav Jain
    Capgemini
    ------------------------------



  • 5.  RE: Unable to listen for requests on address/port

    Posted 6 days ago
    Thank you for responding to my Question...Danny, Srikanth and Vaibhav ...

    If we restart VSE service then its working fine for some time.

    it's simple web service and have couple of JDBG steps integrated with in the VSM..

    please share if you guys have any other solution to fix this issue? 

    Thanks,
    Venu


  • 6.  RE: Unable to listen for requests on address/port

    Posted 5 days ago

    Hi,

     

    If you have JDBC steps involved then it might be that your JDBC connection pool is too small.

     

    Unfortunately, right now, I cannot locate the property name with which you can increase that pool. Maybe another community member has that piece of info readily available?

     

    Cheers,

    Danny

     

    ::DISCLAIMER::

    The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only. E-mail transmission is not guaranteed to be secure or error-free as information could be intercepted, corrupted, lost, destroyed, arrive late or incomplete, or may contain viruses in transmission. The e mail and its contents (with or without referred errors) shall therefore not attach any liability on the originator or HCL or its affiliates. Views or opinions, if any, presented in this email are solely those of the author and may not necessarily reflect the views or opinions of HCL or its affiliates. Any form of reproduction, dissemination, copying, disclosure, modification, distribution and / or publication of this message without the prior written consent of authorized representative of HCL is strictly prohibited. If you have received this email in error please delete it and notify the sender immediately. Before opening any email and/or attachments, please check them for viruses and other defects.






  • 7.  RE: Unable to listen for requests on address/port

    Posted 5 days ago
    You can set below properties in your lisa.properties file for pool setting:

    lisadb.pool.common.minPoolSize=0
    lisadb.pool.common.maxPoolSize=10 

    Thanks.

    ------------------------------
    Regards,
    Vaibhav Jain
    Capgemini
    ------------------------------



  • 8.  RE: Unable to listen for requests on address/port

    Posted 5 days ago
    Hi Vaibhav,

    JDBC pool setting properties are already added into lisa.properties.

    Thanks,
    Venu


  • 9.  RE: Unable to listen for requests on address/port

    Posted 4 days ago
    Hi,

    To my knowledge the above are the pool settings for the registry database and this connection pool is not used by the JDBC step as part of a workflow. I vaguely seem to remember that there is a property which controls the size of the pool used by JDBC steps. (please correct me on this should I be wrong) Unfortunately I have not been able to locate the name of that property yet.

    Can I also ask, the problem with "Address already in use: bind" is solved, correct? Is this a subsequent issue? (Otherwise, this JDBC pool setting thread would be a red herring)

    ------------------------------
    Cheers,
    Danny
    ------------------------------



  • 10.  RE: Unable to listen for requests on address/port

    Posted 2 days ago
    For JDBC asset-specific connection pool, you can configure below properties in lisa.properties file:

    lisa.jdbc.asset.pool.size
    lisa.jdbc.pool.minPoolSize
    lisa.jdbc.pool.maxPoolSize
    lisa.jdbc.pool.maxIdleTime (0= never expires, Default value is 45)

    Regards,
    Vaibhav J

    ------------------------------
    Regards,
    Vaibhav Jain
    Capgemini
    ------------------------------



  • 11.  RE: Unable to listen for requests on address/port

    Posted 2 days ago
    @Vaibhav, Thanks for locating these​

    @Venu, Don't change properties in lisa.properties, best practice is to leave those as is and make any needed change to a property in local.properties. (Or better, to have a specific properties file for each lisa server process​).​

    ------------------------------
    Cheers,
    Danny
    ------------------------------



  • 12.  RE: Unable to listen for requests on address/port

    Posted 2 days ago
    @ Danny.

    thanks for your suggestion.​