Automic Workload Automation

Expand all | Collapse all



    Posted 10-24-2017 11:24 AM
    I've run into issue where a REST WebService job returns a very large payload. I want to store this in an XML Vara but I get the following error:
    U00020821 Runtime error in object '***', line '00000': Value of paramter '3' too long. Allowed length is '1048576' because of system setting MAX_VARIABLE_SIZE.
    I wasnt able to find the setting MAX_VARIABLE_SIZE so I tried adding it too UC_SYSTEM_SETTINGS and increasing it, but it doesnt seem to have made a difference. Job is still failing with the same error, with
    Allowed length is '1048576'
    Has anyone come across this, and know if this setting can be changed, and if so, how?


    Posted 10-24-2017 12:05 PM
    I used Agent Ransack to look for this setting, hoping to find it in a CONFIG or INI file.  All it found was 4 references inside of UCSJ.DLL, and this message which occurs frequently in our WP log files;

    20170217/160017.391 - U00011847 'MAX_VARIABLE_SIZE' set to '001048576'.

    So I don't see that this value can be modified?


    Posted 10-25-2017 03:18 AM
    Thank you both. It seems my best option is to filter the response at the WebService level, so I do not run into this constraint in Automic


    Posted 10-25-2017 12:56 AM
    The max value for MAX_VARIABLE_SIZE is 1 MB and cannot be increased.
    Can you limit the output by either using:

    • XPath
    • XQuery
    • JSONPath
    • JSON to XML and XQuery
    Or Groovy?