DX Infrastructure Management

Expand all | Collapse all

2 UMP's on one primary hub

Jump to Best Answer
  • 1.  2 UMP's on one primary hub

    Posted 7 days ago
    Can you have two UMP's running in one domain? We have problems getting one to run USM but a group is using the restapi interface.  I want to see if I can do a clean install of ump and get usm up.


  • 2.  RE: 2 UMP's on one primary hub

    Posted 7 days ago
    See the documentation section on multiple ump installations

    ------------------------------
    Gene Howard
    Principal Support Engineer
    Broadcom
    ------------------------------



  • 3.  RE: 2 UMP's on one primary hub

    Posted 7 days ago
    https://docops.ca.com/ca-unified-infrastructure-management/9-0-2/en/installing/install-unified-management-portal-ump/configure-multiple-ump-servers/ 
     
    thanks,

    Jason Allen
    Principal Support Engineer (Technical Support Engineer 4)  | Enterprise Software Division



    Broadcom Inc.

    3333 Walnut St  | Boulder, CO 80301
    jason.allen@broadcom.com   | broadcom.com







  • 4.  RE: 2 UMP's on one primary hub

    Posted 7 days ago
    This is 8.3.1. Can the second one be standalone?  If I can get it working I will shutdown the other one.


  • 5.  RE: 2 UMP's on one primary hub

    Posted 7 days ago
    Is it the same for 8.3.1?


  • 6.  RE: 2 UMP's on one primary hub

    Posted 7 days ago
    Yes same for 8.31

    ------------------------------
    Gene Howard
    Principal Support Engineer
    Broadcom
    ------------------------------



  • 7.  RE: 2 UMP's on one primary hub

    Posted 6 days ago
    Edited by Keith Clay 6 days ago


    So I installed the second ump/usm and after a lot of troubleshooting, the udm_manager is not running. It's in a infinite start then fail then start then fail cycle.

    Here is the debug log. I'm not sure what this is telling me.  The data_engine is running fine.  

    Oct 10 18:05:29:521 INFO  [main, udm_manager] ****************[ Starting ]**************** 

    Oct 10 18:05:29:521 INFO  [main, udm_manager] 8.31 

    Oct 10 18:05:29:521 INFO  [main, udm_manager] CA 

    Oct 10 18:05:29:523 INFO  [main, udm_manager] port=48042, pid=0 

    Oct 10 18:05:29:537 INFO  [main, udm_manager] Login to NimBUS is OK 

    Oct 10 18:05:29:537 DEBUG [main, udm_manager] About to run datomic_database_create.sql 

    Oct 10 18:05:29:963 DEBUG [main, udm_manager] Writing transactor properties file. 

    Oct 10 18:05:29:970 DEBUG [main, udm_manager] Launching transactor. 

    Oct 10 18:05:31:951 WARN  [main, udm_manager] stderr: log4j:WARN No appenders could be found for logger (org.jboss.logging). 

    Oct 10 18:05:31:951 WARN  [main, udm_manager] stderr: log4j:WARN Please initialize the log4j system properly. 

    Oct 10 18:05:31:951 WARN  [main, udm_manager] stderr: log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info. 

    Oct 10 18:05:32:509 DEBUG [main, udm_manager] Launched transactor. 

    Oct 10 18:05:32:509 DEBUG [main, udm_manager] Trying to establish Datomic connection. 

    Oct 10 18:05:32:509 DEBUG [main, udm_manager] Initializing Datomic connection 

    Oct 10 18:05:32:509 DEBUG [main, udm_manager] Calling Peer.createDatabase to establish Datomic connection. 

    Oct 10 18:05:32:510 DEBUG [main, udm_manager] Datomic URL: datomic:sql://udm?jdbc:sqlserver://;serverName=the_db;databaseName=NimsoftSLM;applicationName=udm_manager;user=the_user;password=the_pass;sendStringParametersAsUnicode=false 

    Oct 10 18:05:32:742 DBLOW [clojure-agent-send-off-pool-1, udm_manager] Handling metrics callback: {:AvailableMB 1940.0} 

    Oct 10 18:05:33:911 DEBUG [main, udm_manager] Exception establishing Datomic connection: Error communicating with HOST the_IP on PORT 4334 

    Oct 10 18:05:36:913 DEBUG [main, udm_manager] Calling Peer.createDatabase to establish Datomic connection. 

    Oct 10 18:05:36:913 DEBUG [main, udm_manager] Datomic URL: datomic:sql://udm?jdbc:sqlserver://;serverName=the_server;databaseName=NimsoftSLM;applicationName=udm_manager;user=the_user;password=the_pass;sendStringParametersAsUnicode=false 

    Oct 10 18:05:37:927 DEBUG [main, udm_manager] Exception establishing Datomic connection: Error communicating with HOST the_IP on PORT 4334 

    Oct 10 18:05:40:928 DEBUG [main, udm_manager] Calling Peer.createDatabase to establish Datomic connection. 

    Oct 10 18:05:40:928 DEBUG [main, udm_manager] Datomic URL: datomic:sql://udm?jdbc:sqlserver://;serverName=the_server;databaseName=NimsoftSLM;applicationName=udm_manager;user=the_user;password=the_pass;sendStringParametersAsUnicode=false 

    Oct 10 18:05:41:944 DEBUG [main, udm_manager] Exception establishing Datomic connection: Error communicating with HOST the_IP on PORT 4334 

    Oct 10 18:05:44:944 DEBUG [main, udm_manager] Calling Peer.createDatabase to establish Datomic connection. 

    Oct 10 18:05:44:944 DEBUG [main, udm_manager] Datomic URL: datomic:sql://udm?jdbc:sqlserver://;serverName=the_server;databaseName=NimsoftSLM;applicationName=udm_manager;user=the_user;password=the_pass;sendStringParametersAsUnicode=false 

    Oct 10 18:05:45:072 DEBUG [main, udm_manager] Trying to connect to Datomic. 

    Oct 10 18:05:51:634 DEBUG [main, udm_manager] Connected to Datomic: {:db-id "udm-879181cb-14cd-4af2-81e0-3a497ff49b10", :index-rev 6, :basis-t 2535646, :next-t 2535647, :unsent-updates-queue 0, :pending-txes 0} 

    Oct 10 18:05:51:634 DEBUG [main, udm_manager] Established Datomic connection: {:db-id "udm-879181cb-14cd-4af2-81e0-3a497ff49b10", :index-rev 6, :basis-t 2535646, :next-t 2535647, :unsent-updates-queue 0, :pending-txes 0} 

    Oct 10 18:05:51:634 DEBUG [main, udm_manager] Generating schema. 

    Oct 10 18:05:51:634 DEBUG [main, udm_manager] Initializing UDM metadata. 

    Oct 10 18:05:51:845 DEBUG [main, udm_manager] Installing schema. 

    Oct 10 18:05:52:774 DEBUG [main, udm_manager] Installing schema metadata. 

    Oct 10 18:05:52:804 DEBUG [main, udm_manager] Schema installed successfully. 

    Oct 10 18:05:52:804 DEBUG [main, udm_manager] Storing schema metadata. 

    Oct 10 18:05:52:843 DEBUG [main, udm_manager] Unable to generate UDM schema. 

    Oct 10 18:05:52:843 ERROR [main, udm_manager] java.lang.NullPointerException 

    at com.nimsoft.udm.schema.MetadataStorer.queryExistingEntities(MetadataStorer.java:207) 

    at com.nimsoft.udm.schema.MetadataStorer.init(MetadataStorer.java:199) 

    at com.nimsoft.udm.schema.MetadataStorer.store(MetadataStorer.java:179) 

    at com.nimsoft.udm.manager.probe.DbInitializer.generateDatomicSchema(DbInitializer.java:110) 

    at com.nimsoft.udm.manager.probe.ManagerProbe.initialize(ManagerProbe.java:117) 

    at com.nimsoft.pf.ProbeFramework.initialize(ProbeFramework.java:170) 

    at com.nimsoft.nimbus.PFProbe.initialize(PFProbe.java:488) 

    at com.nimsoft.udm.manager.probe.ManagerProbe.main(ManagerProbe.java:59) 

    Oct 10 18:05:52:843 DEBUG [main, udm_manager] Shutting down the peer. 

    Oct 10 18:05:52:862 FATAL [main, udm_manager] Error initializing probe: (1) error, Unable to generate UDM schema.: null 

    Oct 10 18:05:52:862 FATAL [main, udm_manager] (1) error, Unable to generate UDM schema.: null 

    at com.nimsoft.udm.manager.probe.DbInitializer.generateDatomicSchema(DbInitializer.java:115) 

    Caused by: java.lang.NullPointerException 

    ... 4 more 

    Oct 10 18:05:52:862 FATAL [main, udm_manager] Probe exception: (0) , Failed to initialize probe lifecycle: (1) error, Unable to generate UDM schema.: null 

    Oct 10 18:05:52:863 FATAL [main, udm_manager] (0) , Failed to initialize probe lifecycle: (1) error, Unable to generate UDM schema.: null 

    at com.nimsoft.pf.ProbeFramework.initialize(ProbeFramework.java:173) 

    Oct 10 18:05:54:478 DEBUG [main, udm_manager] BEGIN -- NimRequest for 'get_info', against 'controller' 

    Oct 10 18:05:54:499 DEBUG [main, udm_manager] END   -- NimRequest for 'get_info', against 'controller' 

    Oct 10 18:05:54:950 DEBUG [main, udm_manager] Creating probe config. 

    Oct 10 18:05:54:953 INFO  [main, udm_manager] Additional transactor logs are located under the directory transactor-log. 

    Oct 10 18:05:54:953 DEBUG [main, udm_manager] Looking up database connection info. 

    Oct 10 18:05:55:451 INFO  [main, udm_manager] dbProvider: SQLOLEDB jdbcUrl: jdbc:sqlserver://;serverName=the_server;databaseName=NimsoftSLM;applicationName=udm_manager 

    Oct 10 18:05:55:451 DEBUG [main, udm_manager] connectionInfo = jdbc:sqlserver://;serverName=the_server;databaseName=NimsoftSLM;applicationName=udm_manager 

    Oct 10 18:05:55:451 DEBUG [main, udm_manager] Created ManagerProbe. 

    Oct 10 18:05:55:456 INFO  [main, udm_manager] ****************[ Starting ]**************** 

    Oct 10 18:05:55:456 INFO  [main, udm_manager] 8.31 

    Oct 10 18:05:55:456 INFO  [main, udm_manager] CA


  • 8.  RE: 2 UMP's on one primary hub

    Posted 6 days ago
    Keith -

    Please check to see if the following Knowledge Document resolves this issue for you:

    KB95438 : USM Issue

    ------------------------------
    Kathy Maguire
    Technical Support Engineer 4
    Broadcom
    ------------------------------



  • 9.  RE: 2 UMP's on one primary hub

    Posted 5 days ago
    I get an error when I click on the link that it's not found

    The issue seems to be udm_manager is not starting at all


  • 10.  RE: 2 UMP's on one primary hub
    Best Answer

    Posted 5 days ago

    Keith -

    I was having trouble with getting access to external Knowledge Documents earlier today.  I just tested the link again and it works.

    But in case you still cannot access the document, here is the pertinent information from it:

    The problem was cause by using an unsupported JRE 1.8

    In the udm_manager.log, the following type of errors are present...

    ay 03 10:35:19:909 INFO [main, udm_manager] Additional transactor logs are located under the directory transactor-log.
    May 03 10:35:19:950 INFO [main, udm_manager] ****************[ Starting ]****************
    May 03 10:35:19:950 INFO [main, udm_manager] 8.31
    May 03 10:36:57:028 ERROR [main, udm_manager] java.lang.NullPointerException
    at com.nimsoft.udm.schema.MetadataStorer.queryExistingEntities(MetadataStorer.java:207)
    at com.nimsoft.udm.schema.MetadataStorer.init(MetadataStorer.java:199)
    at com.nimsoft.udm.schema.MetadataStorer.store(MetadataStorer.java:179)
    at com.nimsoft.udm.manager.probe.DbInitializer.generateDatomicSchema(DbInitializer.java:110)
    at com.nimsoft.udm.manager.probe.ManagerProbe.initialize(ManagerProbe.java:117)
    at com.nimsoft.pf.ProbeFramework.initialize(ProbeFramework.java:170)
    at com.nimsoft.nimbus.PFProbe.initialize(PFProbe.java:488)
    at com.nimsoft.udm.manager.probe.ManagerProbe.main(ManagerProbe.java:59)

    May 03 10:36:57:050 FATAL [main, udm_manager] Error initializing probe: (1) error, Unable to generate UDM schema.: null
    May 03 10:36:57:050 FATAL [main, udm_manager] (1) error, Unable to generate UDM schema.: null
    at com.nimsoft.udm.manager.probe.DbInitializer.generateDatomicSchema(DbInitializer.java:115)
    at com.nimsoft.udm.manager.probe.ManagerProbe.initialize(ManagerProbe.java:117)
    at com.nimsoft.pf.ProbeFramework.initialize(ProbeFramework.java:170)
    at com.nimsoft.nimbus.PFProbe.initialize(PFProbe.java:488)
    at com.nimsoft.udm.manager.probe.ManagerProbe.main(ManagerProbe.java:59)
    Caused by: java.lang.NullPointerException
    at com.nimsoft.udm.schema.MetadataStorer.queryExistingEntities(MetadataStorer.java:207)
    at com.nimsoft.udm.schema.MetadataStorer.init(MetadataStorer.java:199)
    at com.nimsoft.udm.schema.MetadataStorer.store(MetadataStorer.java:179)
    at com.nimsoft.udm.manager.probe.DbInitializer.generateDatomicSchema(DbInitializer.java:110)
    ... 4 more

    Check and confirm the current version of JRE being used...
    Go to the hub server, right click on controller and select Configure.  Select the Environment tab.
    You will get a list like
    NIM_JRE_HOME = jre/jre8u102
    NIM_JRE_HOME_1_7 = jre/jre7
    NIM_JRE_HOME_1_8 = jre/jre8u102

    By default, UIM will use the version of JRE assign to NIM_JRE_HOME
     

    UIM: 8.31
    OS: Windows 2008 R2

    UIM 8.31 don't support JRE 1.8.x

    You need to revert back to using JRE 1.7

    On the hub server, stop Nimsoft Robot Watcher
    Edit \Nimsoft\robot\robot.cfg
    Change
         NIM_JRE_HOME = jre/jre8u102
         NIM_JRE_HOME_1_7 = jre/jre7
         NIM_JRE_HOME_1_8 = jre/jre8u102

    To
         NIM_JRE_HOME = jre/jre7
         NIM_JRE_HOME_1_7 = jre/jre7
         NIM_JRE_HOME_1_8 = jre/jre8u102

    Save the file and restart Nimsoft Robot Watcher



    ------------------------------
    Kathy Maguire
    Technical Support Engineer 4
    Broadcom
    ------------------------------