Clarity

 View Only
  • 1.  XOG on command line if SSL is enabled

    Posted Jan 10, 2011 05:31 PM
    Team,

    I'm trying to issue this command on the command line for XOG and it always gives me the error that XOG invoke has failed.

    But when I call it by using the property file, it works fine. I think my command line is missing a key fragment that may be related to SSL being enabled.

    Can anyone tell me if there is something I am missing? Thanks, guys!

    On command line, I get the following error:
    XOG Invoke Failed
    Connection reset
    Turn verbose on for more detail.

    And it does spool an output file, my process_read_out.xml reads:
    <ErrorInformation>
    <Severity>FATAL</Severity>
    <Description>XOG Invoke Failed</Description>
    <Exception type="com.niku.xog.XOGException">Login Failed</Exception>
    </ErrorInformation>


    My xog command on command prompt which fails:
    C:\XOG\bin\xog.bat -servername xyzserver -port number 9999 -input "process_read.xml" -output "process_read_OUT.xml" -username xoguser -password xogpassword -usenewxog true

    My property file which works successfully using the command [xog -propertyfile xog.properties]:
    servername=xyzserver

    #default port number for ssl
    portnumber=9999

    #set to true if running against a SSL enabled server
    sslenabled=true

    #set to true if running against a SSL enabled server in FIPS 140-2 mode
    fipsenabled=false

    input=process_read.xml

    output=process_read_OUT.xml

    username=xoguser
    password=xogpassword


  • 2.  RE: XOG on command line if SSL is enabled

    Posted Jan 11, 2011 04:04 PM
    If you have a non SSL instance of the app server you could try that.
    Looking at the properties you give at the command line they look OK ie the same as what you get when you give the run comman in the bin directory without any parameters. The difference to properties file is that there is no ssl enabled parameter on the command line.
    You could ask support if SLL support when using XOG from command line.

    There must be a reason why you don't want to use the properties file.

    Martti K.


  • 3.  RE: XOG on command line if SSL is enabled

    Posted Jan 14, 2011 04:19 PM

    xoggernaut wrote:

    Team,

    I'm trying to issue this command on the command line for XOG and it always gives me the error that XOG invoke has failed.

    But when I call it by using the property file, it works fine. I think my command line is missing a key fragment that may be related to SSL being enabled.

    Can anyone tell me if there is something I am missing? Thanks, guys!

    On command line, I get the following error:
    XOG Invoke Failed
    Connection reset
    Turn verbose on for more detail.

    And it does spool an output file, my process_read_out.xml reads:
    <ErrorInformation>
    <Severity>FATAL</Severity>
    <Description>XOG Invoke Failed</Description>
    <Exception type="com.niku.xog.XOGException">Login Failed</Exception>
    </ErrorInformation>


    My xog command on command prompt which fails:
    C:\XOG\bin\xog.bat -servername xyzserver -port number 9999 -input "process_read.xml" -output "process_read_OUT.xml" -username xoguser -password xogpassword -usenewxog true

    My property file which works successfully using the command [xog -propertyfile xog.properties]:
    servername=xyzserver

    #default port number for ssl
    portnumber=9999

    #set to true if running against a SSL enabled server
    sslenabled=true

    #set to true if running against a SSL enabled server in FIPS 140-2 mode
    fipsenabled=false

    input=process_read.xml

    output=process_read_OUT.xml

    username=xoguser
    password=xogpassword
    Ok, I tried this and it worked for me:

    C:\XOG\bin\xog.bat -servername xyzserver -portnumber 9999 -sslenabled true -fipsenabled false -username xoguser -password xogpass -input object_read.xml -output object_read_out.xml

    Thanks :)