DX NetOps

Expand all | Collapse all

Upgrade from 2.8 to 3.0

Jump to Best Answer
  • 1.  Upgrade from 2.8 to 3.0

    Posted 12-21-2016 09:10 AM

    Hi,

     

    not sure if anyone else has noticed in the doc for CAPM 2.8 and 3.0, but there has now been a restriction in the version of RHEL that can be used for the Data Repository, 2.8 says that supported version of RHEL is 6.x whereas the docs for 3.0 says version 6.7 is the latest supportable version. of course this puts us in an awkward scenario as we have installed 2.8 on 6.8 and now to upgrade to 3.0. of course its possible to downgrade to 6.7 but i would like to know the reasoning for this restriction?

     

    Thanks

     

    Simon



  • 2.  Re: Upgrade from 2.8 to 3.0

    Posted 12-21-2016 09:15 AM

    Hello Simon,

     

    This is unfortunately a restriction we have no control over.

     

    It is one implemented by HP Vertica who own the HP Vertica Database software which runs on the DR server.

     

    Thanks,

    Michael



  • 3.  Re: Upgrade from 2.8 to 3.0

    Posted 12-21-2016 11:52 AM

    So the previous version of Vertica ran great on 6.8, but the version in PM 3.0 doesn't?  How was this not something communicated in big red flashing letters during all of the lead up to the release of 3.0?



  • 4.  Re: Upgrade from 2.8 to 3.0

    Posted 01-24-2017 06:43 AM

    Hi Simon!

     

    I confirmed with our CA dev Team and CA PM 3.0 is supported at any RedHat 6.x versions, so you will not need to do any downgrade in the Linux OS.



  • 5.  Re: Upgrade from 2.8 to 3.0

    Posted 01-24-2017 11:43 AM

    That is correct yasal01

     

    To ensure we don't risk any confusion here, that is specific to the PC, DA and DC servers in a typical CAPM environment.

     

    The restrictions on OS for the DR per HP Vertica requirements remain in place as far as I know.



  • 6.  Re: Upgrade from 2.8 to 3.0

    Posted 01-24-2017 12:02 PM

    Hi Mike!

     

    Jeffrey Pinard from Dev, confirmed to me that DR works normally at RedHat 6.5 for example, so we can work with CAPM at any RedHat 6.x versions!



  • 7.  Re: Upgrade from 2.8 to 3.0
    Best Answer

    Posted 01-24-2017 12:17 PM

    I confirmed that we can run on 6.0 to 6.7, NOT 6.8 which is NOT currently supported by Vertica.  If any issues arise with vertica due to RHE6.8, customer will not currently get support from vertica.

     

    We should be able to run all parts of the product EXCEPT the DR on 6.8 though.



  • 8.  Re: Upgrade from 2.8 to 3.0

    Posted 01-26-2017 08:17 AM

    Hi Jeffrey

    Can you please find out, from HP if necessary, if there are any plans to fix this to support 6.8? And how soon that might happen?

     

    I don't believe our client will be happy when I tell him that in order to upgrade to PM3.0 they will need to downgrade the DR server to 6.7. In fact a quick search shows a host of security vulnerabilities fixed by 6.8 and I know they will not be comfortable reintroducing those into the environment.

     

    Regards, John



  • 9.  Re: Upgrade from 2.8 to 3.0

    Posted 01-24-2017 12:20 PM

    Thanks for the clarification Jeff



  • 10.  Re: Upgrade from 2.8 to 3.0

     
    Posted 02-13-2017 02:46 PM

    We have got confirmation from HP that they announced support for RH 6.8. 

     

    Vertica announced official RH 6.8 support 2 weeks ago with the version we ship with CAPM 3.0

    We should be fine. We have been testing with it as well.