DX Infrastructure Manager

Expand all | Collapse all

snmpcollector profile still showing baseline when i removed it and the sub system to a new one

  • 1.  snmpcollector profile still showing baseline when i removed it and the sub system to a new one

    Posted 05-11-2018 03:09 PM
      |   view attached

    on the interface i have remove baseline info but when i try to restart the service it comes back. also sub-system id i have it to 1.1.3 it still shows 1.1.19



  • 2.  Re: snmpcollector profile still showing baseline when i removed it and the sub system to a new one

    Posted 05-11-2018 03:29 PM

    I have deleted the profile and restarted ppm, discovery agent and snmp-collector.  Also, when editing the profile I made it inactive just to be safe however no joy.



  • 3.  Re: snmpcollector profile still showing baseline when i removed it and the sub system to a new one

    Posted 05-13-2018 09:46 PM

    What version of snmpcollector are you running ? I've had this issue in the older versions and worked with support to fix it for quite some time without any successes . However I do not see this issue happening in the newer versions of snmpcollector 



  • 4.  Re: snmpcollector profile still showing baseline when i removed it and the sub system to a new one

    Posted 05-11-2018 04:31 PM

    If 'publish alarms' is deselected, is that retained?

    Are both 'compute baseline' & 'dynamic alarm' being deselected?

    Is the problem specific to this one interface?

    After clicking Save are they enabled again, or is it only after the restart?

    Is restart done, or deactivate activate?

    What is the size of the local database?

    C:\Program Files (x86)\Nimsoft\probes\network\snmpcollector\SnmpCollector.mv.db

    What is the revision of snmpcollector?

    What is the revision of controller & hub if on a hub?



  • 5.  Re: snmpcollector profile still showing baseline when i removed it and the sub system to a new one

    Posted 05-14-2018 05:19 AM

    hi, check baseline_engine.BASELINE_CONFIG queue in snmpcollector hub.

    baseline option is controlled by baseline_engine probe. 



  • 6.  Re: snmpcollector profile still showing baseline when i removed it and the sub system to a new one

    Posted 05-14-2018 10:25 AM

    snmp-collector is running at 3.43 hub is 7.92HF10 controller 7.92HF11. I have de-selected all yet it still comes back with baseline and alarms published. I have made the profile inactive first and made all the changes without success.



  • 7.  Re: snmpcollector profile still showing baseline when i removed it and the sub system to a new one

    Posted 05-14-2018 11:15 AM

    Hi -

     

    You may be running into a known issue where the baseline_engine is failing to process requests to remove baselining and alarm thresholds.   To see if this is the reason for the baselines and alarms coming back, try the following:

     

    1.  Deactivate the baseline_engine on the hub where you have the snmpcollector probe deployed

    2.  Rename the cache directory under the baseline_engine probe directory on this hub

    3.  Activate the baseline_engine probe on the hub

    4.  Force a rediscovery of devices from the snmpcollector probe (to rebuild the baseline_engine baselines and alarms threshold cached files if there are any that you have left in place for this probe).

    5.  If you have other probes on this hub or robots managed by this hub where you have activated baselining and/or alarm thresholds, restart these probes (again to rebuild the baseline_engine baselines and alarms threshold cached files).

     

    Hope this helps.



  • 8.  Re: snmpcollector profile still showing baseline when i removed it and the sub system to a new one

    Posted 05-15-2018 02:50 PM

    So was the CL-Cisco-Router-Switch template updated to have Compute Baseline and Dynamic Alarm both deselected?



  • 9.  Re: snmpcollector profile still showing baseline when i removed it and the sub system to a new one

    Posted 05-16-2018 03:45 AM


  • 10.  Re: snmpcollector profile still showing baseline when i removed it and the sub system to a new one

    Posted 05-16-2018 09:11 AM

    yes both are de-selected, and i tried cach_dir to make it old without success. Now will see if the doc above helps.