DX Infrastructure Manager

Expand all | Collapse all

probe_configuration_archive

Jump to Best Answer
  • 1.  probe_configuration_archive

    Posted 04-11-2016 09:58 AM

    Hello, I'm working to setup this probe on a CentOS 6.7 server/primary hub, but having the follow error:

     

    Apr 11 13:53:15:997 [main, probe_configuration_archive] data_engine path = data_engine

    Apr 11 13:53:15:997 [main, probe_configuration_archive] log level=4

    Apr 11 13:53:15:997 [main, probe_configuration_archive] file retention=30

    Apr 11 13:53:15:997 [main, probe_configuration_archive] table retention=90

    Apr 11 13:53:15:997 [main, probe_configuration_archive] Setting probe archive directory at : /home/nimsoft/probe_archive

    Apr 11 13:53:15:997 [main, probe_configuration_archive] Ignoring probes: [spooler, hdb, snmptd, qos_engine, qos_processor, mpse, ppm, alarm_enrichment, remote_control]

    Apr 11 13:53:15:998 [main, probe_configuration_archive] ****************[ Starting ]****************

    Apr 11 13:53:15:998 [main, probe_configuration_archive] Version 1.02

    Apr 11 13:53:15:998 [main, probe_configuration_archive] CA Technologies

    Apr 11 13:53:16:005 [main, probe_configuration_archive] port=48050

    Apr 11 13:53:16:024 [main, probe_configuration_archive] Login to NimBUS is OK

    Apr 11 13:53:17:026 [main, probe_configuration_archive] initProbe()

    Apr 11 13:53:17:026 [main, probe_configuration_archive] Setting callbacktimer

    Apr 11 13:53:17:026 [main, probe_configuration_archive] Gathering Configurations, running inital GetConfigs method

    Apr 11 13:53:17:031 [main, probe_configuration_archive] Database Driver: MySQL

    Apr 11 13:53:17:039 [main, probe_configuration_archive] jdbc:mysql://dbrep-prod-noc01/nimsoftslm?relaxAutoCommit=true

    Apr 11 13:53:17:533 [main, probe_configuration_archive] Create PCA_CFG table.

    Apr 11 13:53:17:533 [main, probe_configuration_archive] Error when running on timer method in main thread. Reason is (1) error, Not able to callback for timer cbOnInit.1000. Reason is java.lang.NullPointerException

     

    I did see similar issues in another thread, but it was fixed by an updated probe. I did do some troubleshooting by following the section in the guide, below is what I got from the recommended command.

     

    [root@nimsoft-prod-noc01 probe_configuration_archive]# ../../../jre/jre7/bin/java -cp lib/* com.nimsoft.field.probe_configuration_archive.PCAProbe

    Error: Could not find or load main class lib.nimlookup-1.0.16.jar

     

    Anyone have the same issue? That file it states it cannot find does exist so it makes me believe that it's having an issue loading it?

     

    [root@nimsoft-prod-noc01 probe_configuration_archive]# ll lib

    total 4232

    -rwxr-xr-x. 1 root root  802721 Apr  6 13:15 mysql-connector-java-5.1.20.jar

    -rwxr-xr-x. 1 root root   42925 Apr  6 13:15 nimlookup-1.0.16.jar

    -rwxr-xr-x. 1 root root  171729 Apr  6 13:15 nimsoft.jar

    -rwxr-xr-x. 1 root root 2111220 Apr  6 13:15 ojdbc6-11.2.0.1.0.jar

    -rwxr-xr-x. 1 root root   15636 Apr  6 13:15 probe_configuration_archive.jar

    -rwxr-xr-x. 1 root root  584207 Apr  6 13:15 sqljdbc4.jar

    -rwxr-xr-x. 1 root root  583286 Apr  6 13:15 sqljdbc.jar

    -rwxr-xr-x. 1 root root    8827 Apr  6 13:15 Twofish.jar

     

    Any help is appreciated!



  • 2.  Re: probe_configuration_archive

    Posted 05-22-2016 08:38 PM

    Bumping this in hopes someone else was able to fix this similar issue. I'm at a loss as to what I should try next.



  • 3.  Re: probe_configuration_archive

    Posted 04-13-2016 03:07 PM

    Hi Rick,

     

    A couple of observations here:

     

    1. This is UIM 8.4, correct?

    - Is there anyone out there in the communities that can confirm they have this probe working in 8.4?  I'm sure it would be helpful to Rick to know if it is working for you.

    2. This is MySQL, correct?

    - I know in the original post by Bryan Morrow some other customers had an issue getting this to work with MySQL.  Perhaps you could reach out to them directly to see if they have any pointers.  Additionally, you may want to reach out to Bryan.

    3. Was the table actually created?  I doubt it was due to the placement of the error.

    4. Has the full data_engine path been specified in the config file?  I'm guessing yes since we do see the connection string in the log.

    5. Considering v1.02 of this probe was provided over a year ago it may need some tweaking for the current UIM version.  Not sure.

     

    Hope this helps, and I hope there's someone else out there that might be able to provide some insights.

     

    Good luck!



  • 4.  Re: probe_configuration_archive

    Posted 08-29-2016 11:09 AM

    This is an old version of the probe, please use the latest version that has an internal H2 database as well as multi-threading for scalability.

     

    Configuration Archive - A Custom Multi-threaded UIM Probe 



  • 5.  Re: probe_configuration_archive

    Posted 07-20-2016 05:48 PM

    We have this running on 8.31 on Windows 2012R2 against a MSSQL DB and get the same error.

     

    This is what we're getting:

    Jul 18 19:42:21:853 [main, probe_configuration_archive] Version 1.0

    Jul 18 19:42:21:853 [main, probe_configuration_archive] CA Technologies

    Jul 18 19:42:21:916 [main, probe_configuration_archive] port=48009

    Jul 18 19:42:22:025 [main, probe_configuration_archive] Login to NimBUS is OK

    Jul 18 19:42:23:026 [main, probe_configuration_archive] initProbe()

    Jul 18 19:42:23:026 [main, probe_configuration_archive] Setting callbacktimer

    Jul 18 19:42:23:026 [main, probe_configuration_archive] Gathering Configurations

    Jul 18 19:42:44:951 [main, probe_configuration_archive] Create PCA_CFG table.

    Jul 18 19:42:44:951 [main, probe_configuration_archive] Error when running on timer method in main thread. Reason is (1) error, Not able to callback for timer cbOnInit.1000. Reason is java.lang.NullPointerException

    Jul 20 14:11:47:728 [main, probe_configuration_archive]



  • 6.  Re: probe_configuration_archive

    Posted 04-15-2016 09:05 AM

    Hello Collin,

     

    Yes, this is using UIM 8.4 using MySQL. I did not see the table so assume it was not created. I tried with the full path and without as the data engine was located on the same robot.

     

    Thanks for your reply!

     

    Rick



  • 7.  Re: probe_configuration_archive

    Posted 08-19-2016 10:29 AM

    Still the same here... I gave up on the probe for now, no idea what we really need to do to fix it and I'm out of time to try and troubleshoot it.



  • 8.  Re: probe_configuration_archive
    Best Answer

    Broadcom Employee
    Posted 08-19-2016 11:53 AM

    Hello,

    Are you be able to PING the database from the server where probe is installed?   You need to check the firewall settings too?

    If this doesn't help, please create a support case and we will check the settings for you.

     

    Thanks.

     

    Kind regards

    -Sayeed



  • 9.  Re: probe_configuration_archive

    Posted 08-29-2016 10:59 AM

    Ping is fine.. I did put in a support ticket (case: 00356854) and was told it was third party and no support would be given. Is this not the case anymore?



  • 10.  Re: probe_configuration_archive

    Broadcom Employee
    Posted 08-29-2016 11:02 AM

    Unfortunately this is a community-developed probe so it is not supported officially through the Support channels.

     

    Are you using "Windows Authentication" on the database, or the "sa" user?  Might there be a permissions issue creating the PFA_CFG table?



  • 11.  Re: probe_configuration_archive

    Posted 08-29-2016 11:08 AM

    Thanks for the help!

     

    It's a MySQL DB so it uses a different account that the data engine uses which does not have issues creating other tables. Not sure why this case would be different, have tried looking up whatever I can to turn up logging, maybe some other error would shed more light on the issue.

     

    Rick