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Tech Tip : CA Single Sign-On : Policy Server reports "Failed to write audit log record. Record dropped" lines

  • 1.  Tech Tip : CA Single Sign-On : Policy Server reports "Failed to write audit log record. Record dropped" lines

    Broadcom Employee
    Posted Nov 22, 2017 10:52 AM

    Issue:


    We're putting load on our Policy Server, letting it process a lot of Federation transactions. As soon as we apply the load, Policy Server starts writing these errors in Policy Server log:

    [3083/3264977808][Wed Apr 22 2015 21:03:05][SmReports.cpp:637][ERROR][sm-Server-02700] Failed to write audit log record. Record dropped.
    [3083/3264977808][Wed Apr 22 2015 21:03:08][SmReports.cpp:637][ERROR][sm-Server-02700] Failed to write audit log record. Record dropped.

    Why do we have those error messages and how can we get rid of them?

     

    Environment:


    Policy Server R12.52 SP1


    Cause:


    This error is shown because Audit Messages are produced when the Policy Server does the Federation transaction processing, and Policy Server should have EnableEnhancedTracing registry key enabled. There is a fix in R12.52 SP1 CR08 that shows a message saying that this error because of EnableEnhancedTracing not enabled in the Policy Server registry.

     

    Resolution:


    Upgrade the Policy Server to 12.52SP1CR08 and add the registry key to the Policy Server :

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Netegrity\SiteMinder\CurrentVersion\Reports

    Enable Enhance Tracing= 0x1; DWORD


    Defects Fixed in 12.52 SP1 CR08:

    00302490 DE139629 Policy Server fails to record the audit log


    KB : TEC1668328