AutoSys Workload Automation

 View Only
  • 1.  SFTP "Read timed out"

    Posted Apr 17, 2019 05:43 PM

    I was wondering if anyone has successfully got an SFTP job type to work with WLA DE. I am on 12.1 and continue to get a "Read time out" status and the job goes to SUBERROR. I have tried things such as creating a separate firewall rule to ensure port 22 is open but nothing seems to work.


    Anyone have any steps to troubleshoot this? I am able to ftp a file just fine using the FTP job type and using port 21. The servers that the job is defined to is a Windows 2016, same type server that holds the file that I am trying to FTP

  • 2.  Re: SFTP "Read timed out"

    Broadcom Employee
    Posted Apr 18, 2019 06:53 AM



    One of the reasons that I know that can cause this problem is that ssh may not be enabled to the server machine from the client machine.


    Also , can you confirm if that works fine with a normal sftp command between the two commands outside of DE.


    Thanks and regards,

    Ravi Kiran

  • 3.  Re: SFTP "Read timed out"
    Best Answer

    Posted Apr 18, 2019 12:25 PM

    I was able to get it working now. Still learning about this FTP stuff. I installed OpenSSH and set that up, the job works now.

    Thanks for Ravi for pointing me in the right direction!

  • 4.  Re: SFTP "Read timed out"

    Broadcom Employee
    Posted Apr 22, 2019 12:39 AM

    Thank you. Good to know it helped!