AutoSys Workload Automation

Expand all | Collapse all

SAP Plugin Won't Start

  • 1.  SAP Plugin Won't Start

    Posted 09-11-2015 04:04 PM


    SAP Plugin installed successfully.

     

    1. extracted the sapjco(2.1.9 32 bits at /opt/CA/WorkloadAutomationAE/SystemAgent/WA_AGENT/jars/ext

    2. copied the librfccm.o and libsapjcorfc.so at /opt/CA/WorkloadAutomationAE/SystemAgent/WA_AGENT

    3. Started the cybAgent but received following error

     

    Exception in thread "MainThread" cybermation.agent.CybAgentDriver$CybAgentInstantiationError: Plugin instantiation failed

            at cybermation.agent.CybAgentDriver.runApplication(Unknown Source)

            at cybermation.agent.CybAgentDriver.main(Unknown Source)

    Caused by: cybermation.library.plugins.CybPluginException: Plugin instantiation failed

            at cybermation.agent.plugins.manager.CybPluginManager.invokePluginMethod(Unknown Source)

            at cybermation.agent.plugins.manager.CybPluginManager.loadPlugins(Unknown Source)

            at cybermation.agent.CybAgentDriver.runApplication(Unknown Source)

            ... 1 more

    Caused by: java.lang.reflect.InvocationTargetException

            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:88)

            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:55)

            at java.lang.reflect.Method.invoke(Method.java:618)

            at cybermation.agent.plugins.manager.CybPluginManager.invokePluginMethod(Unknown Source)

            ... 3 more

    Caused by: java.lang.NoClassDefFoundError: com.sap.conn.jco.ext.SessionReferenceProvider

            at java.lang.J9VMInternals.verifyImpl(Native Method)

            at java.lang.J9VMInternals.verify(J9VMInternals.java:94)

            at java.lang.J9VMInternals.initialize(J9VMInternals.java:171)

            at cybermation.plugins.sap.CybSapPluginDriver.runApplication(Unknown Source)

            ... 8 more

    Caused by: java.lang.ClassNotFoundException: com.sap.conn.jco.ext.SessionReferenceProvider

            at java.net.URLClassLoader.findClass(URLClassLoader.java:599)

            at java.lang.ClassLoader.loadClassHelper(ClassLoader.java:760)

            at java.lang.ClassLoader.loadClass(ClassLoader.java:728)

            at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:325)

            at java.lang.ClassLoader.loadClass(ClassLoader.java:707)

            ... 12 more



  • 2.  Re: SAP Plugin Won't Start

    Broadcom Employee
    Posted 09-23-2015 04:19 PM

    Hi Akbardar,

     

    Sorry, this one slipped by me. I have moved this discussion to the Workload Automation Community since the community where this was opened (CA Automation) is for discussions related to CA Server Automation and Automation Suite for Data Centers.

     

    Kind regards,

    Gregg



  • 3.  Re: SAP Plugin Won't Start

    Posted 09-24-2015 01:43 AM

    You have the same question in another thread "SAP Plugin Won't Start after Installing" (CA Workload Automation Agents).



  • 4.  Re: SAP Plugin Won't Start

    Posted 09-25-2015 01:45 PM

    Followups, as lars mentions, should go here: SAP Plugin Won't Start after Installing

     

    Please: one thread per question.



  • 5.  Re: SAP Plugin Won't Start

    Community Manager
    Posted 09-29-2015 01:08 PM

    I've unmarked this as a question -- as noted this is a duplicate.



  • 6.  Re: SAP Plugin Won't Start

    Posted 10-14-2015 12:59 PM

    SAP Plugin, only work with 64 bits Agent.  That was the reason.



  • 7.  Re: SAP Plugin Won't Start

    Posted 10-14-2015 11:45 PM

    Strange we run 32-bit jco 3.0 with a 32-bit agent and it works fine for us, though on Windows but still. Were your agent already on 64 bit when you tried to install the plugin with a 32 bit jco 2.1? That might explain your problems. Anyway, it's nice it works now.