AutoSys Workload Automation

Expand all | Collapse all

SAP Plugin Won't Start after Installing

  • 1.  SAP Plugin Won't Start after Installing

    Posted 09-14-2015 10:14 AM

    SAP Plugin installed successfully.

     

    1. extracted the sapjco(2.1.9 32 bits at /opt/CA/WorkloadAutomationAE/SystemAgent/WA_AGENT/jars/ext

    2. copied the librfccm.o and libsapjcorfc.so at /opt/CA/WorkloadAutomationAE/SystemAgent/WA_AGENT

    3. Started the cybAgent but received following error

     

    Exception in thread "MainThread" cybermation.agent.CybAgentDriver$CybAgentInstantiationError: Plugin instantiation failed

            at cybermation.agent.CybAgentDriver.runApplication(Unknown Source)

            at cybermation.agent.CybAgentDriver.main(Unknown Source)

    Caused by: cybermation.library.plugins.CybPluginException: Plugin instantiation failed

            at cybermation.agent.plugins.manager.CybPluginManager.invokePluginMethod(Unknown Source)

            at cybermation.agent.plugins.manager.CybPluginManager.loadPlugins(Unknown Source)

            at cybermation.agent.CybAgentDriver.runApplication(Unknown Source)

            ... 1 more

    Caused by: java.lang.reflect.InvocationTargetException

            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:88)

            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:55)

            at java.lang.reflect.Method.invoke(Method.java:618)

            at cybermation.agent.plugins.manager.CybPluginManager.invokePluginMethod(Unknown Source)

            ... 3 more

    Caused by: java.lang.NoClassDefFoundError: com.sap.conn.jco.ext.SessionReferenceProvider

            at java.lang.J9VMInternals.verifyImpl(Native Method)

            at java.lang.J9VMInternals.verify(J9VMInternals.java:94)

            at java.lang.J9VMInternals.initialize(J9VMInternals.java:171)

            at cybermation.plugins.sap.CybSapPluginDriver.runApplication(Unknown Source)

            ... 8 more

    Caused by: java.lang.ClassNotFoundException: com.sap.conn.jco.ext.SessionReferenceProvider

            at java.net.URLClassLoader.findClass(URLClassLoader.java:599)

            at java.lang.ClassLoader.loadClassHelper(ClassLoader.java:760)

            at java.lang.ClassLoader.loadClass(ClassLoader.java:728)

            at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:325)

            at java.lang.ClassLoader.loadClass(ClassLoader.java:707)

            ... 12 more



  • 2.  Re: SAP Plugin Won't Start after Installing

    Posted 09-15-2015 01:17 AM

    Have yo tried to increase the memory-parameter in agentparm.txt?

    oscomponent.jvm.x.options=-Xms256m;-Xmx1024m;-Xss128k



  • 3.  Re: SAP Plugin Won't Start after Installing

    Posted 09-25-2015 02:44 PM

    If the memory-parameter does not help. When running sap-plugin on Unix jco 2.1 you need librfccm, libsapjcorfc both in agentinstall-dir and sapjco.jar in jars/ext as you say.

    The sap.jar file is from the sap.pak-file.

    I will rest until my help is needed more We also run jco 3.0 at my site and I am a bit puzzled why you are not, since it is supported and I can from my site promise that it works much better.



  • 4.  Re: SAP Plugin Won't Start after Installing

    Posted 09-15-2015 09:20 AM

    Did you actually install the plugin? or you just copied files in place?

    also there are 2 diff places where the classes and jar files go when u do it by hand.

    i would unwind what you did . and start over.



  • 5.  Re: SAP Plugin Won't Start after Installing

    Posted 09-25-2015 01:49 PM

    We're on to JCO 3, so our installation may not line up.

     

    Where's your sap.jar file?



  • 6.  Re: SAP Plugin Won't Start after Installing

    Community Manager
    Posted 09-29-2015 01:07 PM

    Dar -- were you able to resolve your issue?

     

    Jim, Steve and Lars might be able to help if you can share more information!



  • 7.  Re: SAP Plugin Won't Start after Installing

    Posted 10-14-2015 01:00 PM

    Yes;

     

    SAP Agent has to be 64 bits, not 32 bits.



  • 8.  Re: SAP Plugin Won't Start after Installing

    Posted 10-14-2015 11:49 PM

    Strange we run 32-bit jco 3.0 with a 32-bit agent and it works fine for us, though on Windows but still. Were your agent already on 64 bit when you tried to install the plugin with a 32 bit jco 2.1? That might explain your problems. Anyway, it's nice it works now.