Symantec Access Management

Expand all | Collapse all

CA Web Agent on RHEL 7.3

Jump to Best Answer
  • 1.  CA Web Agent on RHEL 7.3

    Posted 09-13-2018 04:45 AM

    I have installed and configured CA WebAgent on RHEL 7 successfully, but when I try to stop the httpd service it throws below error:

    httpd: Syntax error on line 66 of /opt/apache2/conf/httpd.conf: Cannot load /opt/CA/webagent/bin/libmod_sm24.so into server: /opt/CA/webagent/bin/libmod_sm24.so: wrong ELF class: ELFCLASS32

     

    Environment Details:

    OS: RHEL 7.3 x86_64

    SM: r12.52 SP2

    Web Server: Apache 2.4.34

    Web Agent: 12.52.0.142 32bit

     

    I have checked for all the dependency for libmod_sm24.so using ldd, and all required library are present.

    I have also tried the 64bit version of the web agent but installation fails with below error.

    ./ca-wa-12.52-RedHat-zLinux-64.bin: line 3319: /tmp/install.dir.14143/Linux/resource/jre/bin/java: cannot execute binary file
    ./ca-wa-12.52-RedHat-zLinux-64.bin: line 3319: /tmp/install.dir.14143/Linux/resource/jre/bin/java: Success

     

    If anyone can please suggest on this issue that would be great.



  • 2.  Re: CA Web Agent on RHEL 7.3

    Broadcom Employee
    Posted 09-13-2018 07:36 AM

    Sajid, Please review this to get some tips, similar issue (perhaps WA env script not run, etc.)

    Apache WebAgent configration issue 

    Rgds. Vijay



  • 3.  Re: CA Web Agent on RHEL 7.3

    Posted 09-13-2018 11:16 AM

    Hi Vijay,

     

    Thank you for your response. 

    I had run the WA env script before stopping the httpd service. I have even added the env variables into apachectl script.

    Also, I have tried with all three lib files libmod_sm20.so, libmod_sm22.so and libmod_sm22.so, but getting the same error.

     

    Regards,

    Sajid



  • 4.  Re: CA Web Agent on RHEL 7.3
    Best Answer

    Broadcom Employee
    Posted 09-13-2018 12:49 PM

    If you are using RedHat Apache, source the environment variables in /etc/sysconfig/httpd.

    The ELF class warning is a bit version mis-match.  ca-wa-12.52-RedHat-zLinux-64.bin is not the correct 64bit installer.  The 64bit Linux installer is smwa-12.52-sp01-cr09-linux-x86-64.zip with a bin file name of ca-wa-12.52-sp01-cr09-linux-x86-64.bin.  zLinux is for Linux on the mainframe.



  • 5.  Re: CA Web Agent on RHEL 7.3

    Posted 09-14-2018 05:18 AM

    Hi David,

     

    Thank you for your suggestion. I have downloaded the CR09 Agent ca-wa-12.52-sp01-cr09-linux-x86-64.bin and installed & configured it successfully. It is working fine now.