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Tech Tip : CA Single Sign-On : Unable to connect to the Database in SiteMinder Policy Server due to extra line "QEWSD" in the DSN configuration.

  • 1.  Tech Tip : CA Single Sign-On : Unable to connect to the Database in SiteMinder Policy Server due to extra line "QEWSD" in the DSN configuration.

    Broadcom Employee
    Posted Mar 29, 2019 05:39 AM

    Issue:


    I'm trying to configure the Audit Store, but when the Policy Server
    starts up the smps log shows a message reporting a problem with the
    connection to the Audit Store using ODBC connector :

     

    [27759/1][Thu Jan 24 2008 13:17:42][SmReportsODBCLog.cpp:265][INFO]
    Possible network or configuration problem connecting to Audit Log
    Database

     

    Also as the Policy Store is on ODBC, we see this error too :

     

    smps.log

     

    [HSTMT.cpp:241][Error][ERROR][sm-xpsxps-00810] Native Diagnostic:
    HY000:6091 [DataDirect][ODBC Oracle Wire Protocol driver]The
    DataDirect product you are attempting to access has been provided to
    you by CA Technologies for exclusive use with SiteMinder. You are
    not licensed to use this product with any application other than
    SiteMinder. If you would like to purchase this product for some
    other use, please call 800-876-3101 or visit DataDirect at
    www.datadirect.com

     

    I have configured the Data Source Name (DSN) as described in the
    installation guide and I pretty sure all the information is correct.

     

    My configuration is as follows:

     

    [SiteMinder Logs Data Source]
    QEWSD=38931
    Driver=/apps/siteminder/odbc/lib/NSora21.so
    Description=DataDirect 5.1 Oracle Wire
    ProtocolHostName=oracle-smaudit.ca.com
    PortNumber=1521
    SID=smaudit
    CatalogOptions=0
    ProcedureRetResults=0
    EnableDescribeParam=0
    EnableStaticCursorsForLongData=0
    ApplicationUsingThreads=1

     

    How can we fix this ?


    Environment:

     

    all versions

     

    Cause:

     

    This error is related to license problem with the Data Direct
    Driver. If no serial number is present or is corrupted in the license
    file then the driver will go into evaluation mode and add QEWSD line
    to the data source being initialized.

    When the evaluation period has expired the driver will not allow
    connections to the database.

    Resolution:

     

    Please remove the QEWSD line from your system_odbc.ini file and verify
    that the license file (IVNS.LIC or DDNS.LIC) exists under the
    $NETE_PS_ROOT/odbc directory. If the line shows up again that would
    suggest a problem with the license file and you may need to open a
    case with Siteminder Support. Make sure that the IVNS.LIC or DDNS.LIC
    is written in capitals letters.

     

    Additional Information:

     

    ERROR "THE DATADIRECT ODBC DRIVER YOU ARE ATTEMPTING TO ACCESS HAS BEEN PROVIDED TO YOU BY COMPANY_ABC" WHEN EXECUTING A SQL STATEMENT WITH
    THE CONNECT FOR ODBC DRIVERS
    https://knowledgebase.progress.com/articles/Article/2970

     

    KB : KB000053713