Layer 7 Access Management

Expand all | Collapse all

"Data Source Test Failed" CA Strong Installation

Jump to Best Answer
  • 1.  "Data Source Test Failed" CA Strong Installation

    Posted 09-19-2018 10:56 AM
      |   view attached

    I am attempting to install the CA Strong into my 2016 instance. I have JDK set up, my server created at localhost\SQLSERVER1, a database named SQLDB1, and a user named sqladmin1. As i'm doing the data source test in CA Strong I received the error message:

    "Checking Primary DB Connectivity..."

    "Testing database connectivity...failed"

    "Backup DB not configured"

    "Data Source Test Failed"

     

    Can someone help troubleshoot this?



  • 2.  Re: "Data Source Test Failed" CA Strong Installation

    Posted 09-19-2018 11:31 AM

    Hi Adrian, Try giving the actual HOSTNAME or IP address in of the machine where your sql server is installed which is your local machine and see if that helps. Give this in the "server" field

     

    Thanks
    Awijit 



  • 3.  Re: "Data Source Test Failed" CA Strong Installation

    Posted 09-19-2018 11:36 AM

    Thank you Awijit, unfortunately I still receive the same error, in both cases. Any other ideas?



  • 4.  Re: "Data Source Test Failed" CA Strong Installation

    Posted 09-19-2018 12:11 PM

    Hi Adarian, that is weird. Is a database named SQLDB1 already created ?



  • 5.  Re: "Data Source Test Failed" CA Strong Installation

    Posted 09-19-2018 12:15 PM

    Yes Awijit, this is how I have it set in Server Management Studio. I've tried changing the server name to what is listed and it doesn't work either.



  • 6.  Re: "Data Source Test Failed" CA Strong Installation
    Best Answer

    Posted 09-19-2018 01:32 PM

    Thank you for the help, I figured out the issue was that it was because I was using SQL Server 2014 Express; my server was not listening to Port 1433, so I went to enable TCP/IP in Server Configuration Manager, then entered 1433 in the IPALL of the IP Addresses.



  • 7.  Re: "Data Source Test Failed" CA Strong Installation

    Posted 04-11-2019 06:59 AM

    Hi, we faced in the same error, I can ping the oracle db and I can reach the db on port 1521 with a telnet. How can I see the log? I'm in the installation phase is there any location where I can find some installing logs?

    We have Oracle RAC 12.2

     

    The error is the same

    "Testing database connectivity...failed"

    "Backup DB not configured"

    "Data Source Test Failed"

    Data Source Test Failed

    Thanks

    Vittoria



  • 8.  Re: "Data Source Test Failed" CA Strong Installation

    Posted 04-25-2019 03:33 PM

    The logs will be generated after installation. Are you able to connect to this host and port from this machine using terminal or cmd ?

    Can you check if that port is open ?

    Is there any firewall blocking that port ?