Symantec Access Management

 View Only
  • 1.  CA Advanced Authentication 8.1

    Posted Nov 09, 2016 04:42 AM

    Hi Guys,


    I have installed the CA Advanced Authentication 8.1 like folloiwng:


    1. strong authentication

    2. Risk authentication

    3. Adapter

    4. Tomcat 7.

    5. Database Oracle 12c.

    In Tomcat i have deployed arcot admin and ArcotAFMWizard, while creating the AFM profiles, i get the Null pointer exception like below, all other services are running with out any issues, but not sure why i see this error when saving the AFM profiles.


    at com.arcot.afm.wizard.helpers.PropertyFileWriter.writeToFile(PropertyF
    at org.apache.jsp.wizard_002d9_jsp._jspService(
    at org.apache.jasper.runtime.HttpJspBase.service(
    at javax.servlet.http.HttpServlet.service(
    at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper
    at org.apache.jasper.servlet.JspServlet.serviceJspFile(
    at org.apache.jasper.servlet.JspServlet.service(
    at javax.servlet.http.HttpServlet.service(
    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Appl
    at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationF
    at org.apache.tomcat.websocket.server.WsFilter.doFilter(
    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Appl
    at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationF
    at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperV
    at org.apache.catalina.core.StandardContextValve.invoke(StandardContextV
    at org.apache.catalina.authenticator.AuthenticatorBase.invoke(Authentica
    at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.j
    at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.j
    at org.apache.catalina.valves.AccessLogValve.invoke(
    at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineVal
    at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.jav
    at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp
    at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.
    at java.util.concurrent.ThreadPoolExecutor$
    at org.apache.tomcat.util.threads.TaskThread$




  • 2.  Re: CA Advanced Authentication 8.1

    Posted Nov 09, 2016 09:55 AM

    Make sure you are running JDK 7.x 64bit.


    Check the install logs to verify no errors.


    Check all logs to make sure each services have started successfully.

  • 3.  Re: CA Advanced Authentication 8.1

    Posted Nov 09, 2016 12:25 PM

    Hello Jack,


    Thanks for the reply, I am using JDK 1.7.079 but not 64-bit. as i am using single system in a POC environment i have insstalled 32-bit jdk and tomcat 7.072


    Does the bitness of JDK make any difference?


    I have checked each and every log, everything is installed correctly and no errors in logs. except that / file missing in arcotafm.log. The basic thing Wizard is not related to any service or database i guess it is just collecting info to generate the properties file at the end.




  • 4.  Re: CA Advanced Authentication 8.1
    Best Answer

    Posted Nov 10, 2016 12:54 AM

    Hello Jack,

    The issue is solved. Seems there was a permission problem in the AFM_HOME to generate the properties file.

    Initial Setup (where issue was there)
    1. I used portable tomcat just extract the zip file and use the tomcat by just adding jdk path in catalina.
    2. open the command prompt as administrator and run the tomcat startup.bat to access the services.
    3. Not sure even though i was running tomcat in administrative privilege AFM profiles was generating any properties files.

    Second setup ( where issue solved):
    1. I downloaded tomcat installer tomcat7.exe
    2. Installed software as service with administrator privileges
    3. Re-Deployed all the war files
    4. added the JDNI connections required for state manager
    5. created the AFM profiles with out any issues, tomcat was able to generate the properties files in AFM_HOME/conf/afm

    6. JDK is 32-bit and tomcat is 7.0.72 32-bit, CA advance authentication 8.1 32-bit