Symantec Access Management

Expand all | Collapse all

Error: Exception User might not have required permissions to get group information

Jump to Best Answer
  • 1.  Error: Exception User might not have required permissions to get group information

    Posted 03-23-2016 04:08 AM

    Dear Folks,

     

    My SPS R12.52SP1on RedHat6 Linux 64 bit is running fine.

    But I'm seeing a strange error message in Proxy UI after login.

    "Error: Exception User might not have required permissions to get group information".

    Added a single normal user(to login into proxy-ui)to the 'Proxy UI' Policy in SiteMinder(this user not an administrator in siteminder).

     

    Screen Shot 2016-03-23 at 1.30.20 PM.png

    Strange thing is that, error will appear if we navigate back from another tab as below,

    Proxy Rules --> Virtual Hosts(erro gone here in this tab) --> Proxy Rules (error gone here also)

     

    Any ideas what is the root cause? How can we fix it? Is this something related to "Configuration" issue..

     

    My SPS enabled as Federated Gateway working as expected.

     

    Regards,

    Chiranjeevi



  • 2.  Re: Error: Exception User might not have required permissions to get group information
    Best Answer

    Broadcom Employee
    Posted 03-23-2016 04:32 PM

    Hi Chiranjeevi,

     

    What is the exact build of SPS that you are using?  This can be obtained from the server.log file under the proxy engine.  There is a fix in build 686.  If you are at a build lower than this then I suggest you upgrade to 12.52-SP1-CR04 which is our latest build.

     

     

    Regards,

    Sandy



  • 3.  Re: Error: Exception User might not have required permissions to get group information

    Posted 03-23-2016 09:47 AM

    Which CR are you using? And how are your Siteminder WAM UI administrators protected (AD/LDAP)? I had this same problem and I was told its a bug on CR04 SPS.



  • 4.  Re: Error: Exception User might not have required permissions to get group information

    Posted 03-23-2016 04:43 PM

    Hi Sandy,

     

    "Build Number=499" which i have found in ca-sps-version.info as below,

    ************************************************************************

    Product Name=CA SiteMinder Secure Proxy Server

    FullVersion=12.52.0100.499

    Version=12.52

    Update=0100

    Build Number=499

    Location=/opt/CA/secure-proxy

    InstanceName=default

    ************************************************************************

     

    I'm not sure about CR number. it may be CR01.

    Can you tell me how can i find it?

    Appreciate your help

     

    Regards,

    Chiranjeevi

     

     

     



  • 5.  Re: Error: Exception User might not have required permissions to get group information

    Posted 03-23-2016 04:39 PM

    Hi Sukesh,

     

    I'm not sure it may be CR01, i simply downloaded linux version of SPS from downloads.

     

    Can you tell me how can i check the CR01 in installation server?

    There's only one WAMUI administrator we have i.e. siteminder. We're using AD as User directory.

     

    Regards,

    Chiranjeevi



  • 6.  Re: Error: Exception User might not have required permissions to get group information

    Posted 03-24-2016 09:48 AM

    Couple of things here, The user you have added to ProxyUI policy(under SPS Domain) should be added as an admin on Siteminder WAM UI.  From your notes you only have one admin account that's Siteminder, you need to configure administration authentication on WAM UI(link).