Service Operations Insight

 View Only
Expand all | Collapse all

Escalation policies not working

Jump to Best Answer
  • 1.  Escalation policies not working

    Posted Dec 29, 2016 04:38 AM

    Hello Guys,

     

    I have created a new escalation policies and actions to assigned value to User Attribute 3. At the first, policies is running as expected but when the alert is updated, the value for user attribute back to null values. For more details please see below picture:

    At the first:

     

    After 5-10 minutes

     

    and here are the configurations for My Policies.

     

     

    Does anyone have experience with this?

     

    Best Regards,

    Okik



  • 2.  Re: Escalation policies not working

    Posted Dec 29, 2016 04:53 AM

    Hi Okik,

     

    Can you share alert history (Export in Excel if it is huge) for an example for a alert when UserAttribute was updated and it is now showing blank after alert update.

     

    Thanks,

    Ashay



  • 3.  Re: Escalation policies not working

    Posted Dec 29, 2016 05:09 AM

    Hi Ashay,

     

    Thanks for the reply . Here is the alert history:

     

    Best Regards,

    Okik



  • 4.  Re: Escalation policies not working

    Posted Dec 29, 2016 09:00 AM

    Hi Okik,

     

    This is what I see, Values for UserAttribute3 undated 

    1. Dec 29 3:55:46 PM ICT - Updated with JVM

    2. Dec 29 3:56:39 PM ICT - Updated with Blank Value

    3. Dec 29 4:13:13 PM ICT - Updated with JVM

    4. Dec 29 4:13:45 PM ICT - Updated with Blank

     

    Its been long time for me to worked on SOI. Looks like it needed some patch. SOI experts may help you on this.

    Brahma MichaelBoehm

     

    Thanks,

    Ashay



  • 5.  Re: Escalation policies not working

    Broadcom Employee
    Posted Dec 29, 2016 09:18 AM

    Hi Okik,

     

    Can you explain "when the alert is updated"?

    Does it mean that the alert is being updated by connector or any escalation action?

     

    Thanks

    Brahma



  • 6.  Re: Escalation policies not working

    Posted Dec 29, 2016 09:23 AM

    Hi Brahma,

     

    Thanks for the reply. I means when the alert is being updated by connector.

     

    Best Regards,

    Okik



  • 7.  Re: Escalation policies not working

    Broadcom Employee
    Posted Dec 29, 2016 09:27 AM

    Couple of questions...

    => Is the problem with only SNMP Connector alerts or all?

    => When alert is updated means, the same alert property is being updated?

    Please raise a case with CA Support for further research on this.

     

    Thanks

    Brahma



  • 8.  Re: Escalation policies not working

    Posted Dec 29, 2016 09:42 AM

    Is this because of SNMP connector publishing it as a NEW alert with same AlertID every time, rather publishing it as UPDATEED alert ?

     

    Thanks,

    Ashay



  • 9.  Re: Escalation policies not working

    Posted Dec 29, 2016 09:56 PM

    Hi Brahma,

     

    => Is the problem with only SNMP Connector alerts or all?

    No, this problem occurs also for APM Connector (SNMP Alert Action).

     

    => When alert is updated means, the same alert property is being updated?

    I think so, because when the alert is being updated, assigned value for user attribute is back to null values.

     

    I have also tried temporary solution but it still does not work.

    https://www.ca.com/us/services-support/ca-support/ca-support-online/knowledge-base-articles.TEC1583779.html 

     

    Parallel, I will raise this issue to CA Support.

     

    Thanks,

    Okik



  • 10.  Re: Escalation policies not working

    Posted Dec 30, 2016 02:22 AM

    If I remember correctly, I had the similar issue a while back with parsing values from the message to userAttributes for APM Connector Alarms. I had to apply a patch. Will go back to my calls and see if I can find it, then will update it here.



  • 11.  Re: Escalation policies not working
    Best Answer

    Posted Dec 30, 2016 02:27 AM

    Found it. I was running SOI v4.0 cum1. Patch is RO91532.



  • 12.  Re: Escalation policies not working

    Broadcom Employee
    Posted Jan 03, 2017 12:32 PM

    Hi Okik,

    Based on the above suggestions, if 4.0 Cum 1 patch RO19532 does not help resolve the issue, please open a support case to review further if not done so already. Since a support case is being suggested, this thread is being marked as answered. To help others, please place the solution in this thread when available.