DX Operational Intelligence

Expand all | Collapse all

New AEP Error: Rule not Compiled

Jump to Best Answer
  • 1.  New AEP Error: Rule not Compiled

    Posted 05-17-2016 01:09 PM

    Hello, wondering if anyone ever hit this? SOI v3.3 CUM2 trying to define a new AEP policy and I defined the Policy, Added the Aciton yet when i hit OK, it says:

    ============

    Alert Escalation Policy Error:

    Rule Not Compiled

    OK.

    ============

     

    Figured out that the rule I defined:

              If Summary contains "***CLEAR ALARM*** NETSCALER ENTITY UP" 

    SOI did not like the ***

    Any reason why SOI can't accept the * character?



  • 2.  Re: New AEP Error: Rule not Compiled

    Posted 05-19-2016 07:45 AM

    Hello Daniel,

     

    I see the same error, can you post the Summary details here?

     

    Thanks

    Brahma



  • 3.  Re: New AEP Error: Rule not Compiled

    Posted 05-19-2016 11:33 AM

    Hi Brahmaih,

    Weird today I re-entered it with the entire alert summary details:    ***CLEAR ALARM*** NETSCALER ENTITY UP

    and when I hit OK it worked???

    So the EP definition is:

    Apply to:

    Infrastructure Alerts, Alerts for CIs in maintenance mode, Infrastructure alerts for Services in maintenance mode

    When:

    (Time spent in alert queue exceeds 1500 minute(s)) and ((Summary has-substring-ignore-case ***CLEAR ALARM*** NETSCALER ENTITY UP))

     

    So its working now?



  • 4.  Re: New AEP Error: Rule not Compiled

    Posted 05-25-2016 03:21 PM

    Dan, can i close this one out ?  or is more assistance needed?



  • 5.  Re: New AEP Error: Rule not Compiled
    Best Answer

    Posted 06-02-2016 03:15 AM

    Hi Daniel,

    I just did some tests on my system.

    The initial Save was also failing with the provided string containing *.

    When I removed the * I was able to save the policy.

    Following that, I went back to edit it, added the correct string again (with *) and the update works (I also checked in the DB that the update is reflected).

    I was able to reproduce this several times.

    So only the initial Save seems to have a problem with the special character.

     

    MichaelBoehm