Clarity Service Management

Expand all | Collapse all

Disable Hyperlinks in "Export" Spreadsheet

Jump to Best Answer
  • 1.  Disable Hyperlinks in "Export" Spreadsheet

    Posted 02-04-2019 05:10 PM

    Hello,

     

    When searching, say, incidents or requests in Service Desk Manager and clicking "export" to export the data into a spreadsheet, this action creates a new session.  Hyperlinks are contained within that spreadsheet and upon clicking each one another new session is created.

     

    Is there a way to disable these hyperlinks when Service Desk Manager exports this data?  We want to be able to export the raw data without hyperlinking to prevent unnecessarily-opened multiple sessions.

     

    Thank you for any responses.



  • 2.  Re: Disable Hyperlinks in "Export" Spreadsheet

    Posted 02-04-2019 08:49 PM

    Hello Nick,

     

    SDM will just Export the data that it has, and Excel will just open what it is given.

    So there are a few ways you could approach this.

     

    1) Within MS Excel.

    Each user would configure the option to stop MS Excel from automatically converting hyperlinks, for example:

    https://contexturesblog.com/archives/2009/10/23/stop-automatic-hyperlinks-in-excel/ 

     

    2) Within CA SDM

    Edit the list_<object>.htmpl form so that it does not produce links with "http" in them. 

    You might have a custom List screen for the Export purpose, and another for regular use.

    Or see this post for an example of having a column in the Export which is not visible to users.

     

    3) Use another Report method.

    You might be able to use an SDM Detail Report or a Jaspersoft Report to meet your needs.

     

    Thanks, Kyle_R.



  • 3.  Re: Disable Hyperlinks in "Export" Spreadsheet

    Posted 02-07-2019 02:04 PM

    Kyle,

     

    Thank you so much for your response.  This actually led us down the path to correcting the issue, and what Michael has posted below is what we had discovered was correct for us.  Thank you for such a prompt response, as well!

     

    - Nick



  • 4.  Re: Disable Hyperlinks in "Export" Spreadsheet

    Posted 02-07-2019 09:26 AM

    Hi -

    Another option might be (tested in 17.1):

    copy ~/bopcfg/xslt/excel.xsl to ~/site/mods/xslt and edit this file

    remove the following block in the copy and save

                 <xsl:if test="boolean($tzOffset) or boolean($tzName)">
                    <Comment><Data>
                      <xsl:if test="boolean($tzName)">
                        <xsl:value-of select='$tzName'/>
                      </xsl:if>
                      <xsl:text>&#xA;</xsl:text>
                      <xsl:value-of select='substring(., 20)'/>
                      </Data>
                    </Comment>
                  </xsl:if>

     

    Rerun your export.

     

    Regards

    ..........Michael



  • 5.  Re: Disable Hyperlinks in "Export" Spreadsheet

    Posted 02-07-2019 10:16 AM

    Oh I am sorry !!

    !! My mistake !! Just too hastily.

    This was regarding removing the timezone Information in date columns.

    Will check again

    Regards

    ............Michael



  • 6.  Re: Disable Hyperlinks in "Export" Spreadsheet
    Best Answer

    Posted 02-07-2019 11:18 AM

    So this one might do the trick.
    forget about my previous suggestion (and if already done, remove the copied xsl file again !)

    • if not already existent, make a copy of the htmpl in question (i.e. list_in.htmpl) from bopcfg/www/htmpl/web/analyst to site/mods/www/htmpl/web/analyst and edit the copied file
    • find the line including exportfmt 
    • just remove the part : exportfmt="ShowLink"
    • save the file and do a pdm_webcache
    • redo the data search in the gui and do your export.

    Hope that helps and works

    Regards

    ............Michael



  • 7.  Re: Disable Hyperlinks in "Export" Spreadsheet

    Posted 02-07-2019 02:02 PM

    Michael,

     

    Thank you so much as this was the solution we needed.  This did exactly as we wanted!  We did have to stop and restart the services, but after we did this option took effect.

     

    Thank you again, sir.