CA Service Management

 View Only
Expand all | Collapse all

Hello Everyone, i keep getting this error when i try to create a report using the adhoc view in the jasper reporting tool

Jump to Best Answer
Ayodeji Babadele

Ayodeji BabadeleAug 24, 2018 08:40 AM

Ayodeji Babadele

Ayodeji BabadeleAug 24, 2018 11:24 AM

  • 1.  Hello Everyone, i keep getting this error when i try to create a report using the adhoc view in the jasper reporting tool

    Posted Aug 24, 2018 08:40 AM

    jasper error



  • 2.  Re: Hello Everyone, i keep getting this error when i try to create a report using the adhoc view in the jasper reporting tool

    Broadcom Employee
    Posted Aug 24, 2018 10:07 AM

    Ayodeji-Babadele 

     

    Do the OOTB reports work successfully?

    What version of JasperSoft is installed?

    Any additional errors noted in the JasperSoft logs?



  • 3.  Re: Hello Everyone, i keep getting this error when i try to create a report using the adhoc view in the jasper reporting tool

    Posted Aug 24, 2018 10:19 AM

    1. Yes,  the OOTB reports work well. I am trying to generate a customized report

    2. The version is 6.3

    no additional error log just the install log. 



  • 4.  Re: Hello Everyone, i keep getting this error when i try to create a report using the adhoc view in the jasper reporting tool

    Broadcom Employee
    Posted Aug 24, 2018 10:31 AM

    Ayodeji-Babadele 

    I would recommend opening a CA Support case for further investigation.

    Tibco Support might need to be engaged to determine the cause of this error.



  • 5.  Re: Hello Everyone, i keep getting this error when i try to create a report using the adhoc view in the jasper reporting tool

    Posted Aug 24, 2018 10:36 AM

    Anything of interest in the jasperserver..log file?



  • 6.  Re: Hello Everyone, i keep getting this error when i try to create a report using the adhoc view in the jasper reporting tool

    Posted Aug 24, 2018 11:21 AM

    Also this could be happening becuase of how the domain is defined.  Try creating a adhoc view with a simple domain and see of error disappears.



  • 7.  Re: Hello Everyone, i keep getting this error when i try to create a report using the adhoc view in the jasper reporting tool

    Posted Aug 24, 2018 11:24 AM

    Please what do you mean by simple domain?



  • 8.  Re: Hello Everyone, i keep getting this error when i try to create a report using the adhoc view in the jasper reporting tool

    Posted Aug 24, 2018 03:46 PM

    Maybe I am confused to what you are trying to accomplish?  Please describe the steps you are following that leads to the error.  

     

    Thanks!



  • 9.  Re: Hello Everyone, i keep getting this error when i try to create a report using the adhoc view in the jasper reporting tool

    Posted Aug 27, 2018 04:30 AM
      |   view attached

    Hello Steve,

     

    Yes I am running a script which generates information on the database and am trying to replicate on the jasper tool.

     

    Thanks



  • 10.  Re: Hello Everyone, i keep getting this error when i try to create a report using the adhoc view in the jasper reporting tool

    Posted Aug 28, 2018 01:12 PM

    To create ad Adhoc Report one needs to follow below steps:

     

    1)  Create Domain

    2)  Create an Adhoc View based on the domain

    3)  Create an Adhoc Report based on the Adhoc View.

     

    Based in the comments in this mesage stream it is not clear to me that the steps outlined above has occured.



  • 11.  Re: Hello Everyone, i keep getting this error when i try to create a report using the adhoc view in the jasper reporting tool

    Posted Aug 29, 2018 07:16 AM
      |   view attached

    Hello,

     

    I followed these steps, if am correct it is during the process of creating a domain you can run a script?

     

    Thanks



  • 12.  Re: Hello Everyone, i keep getting this error when i try to create a report using the adhoc view in the jasper reporting tool

    Posted Aug 29, 2018 04:19 AM

    Ayodeji-Babadele

    Please share detail information about requirement, i think that would be best because your OOTB thing working fine, may be your script or connection may require changes.

    Thanks. 



  • 13.  Re: Hello Everyone, i keep getting this error when i try to create a report using the adhoc view in the jasper reporting tool

    Posted Aug 29, 2018 07:10 AM
      |   view attached

    Hello,

     

    I noticed now that one out of the two tables I included in my script is not showing all the columns in jasper whereas I cannot inner join.

     

    Thanks



  • 14.  Re: Hello Everyone, i keep getting this error when i try to create a report using the adhoc view in the jasper reporting tool

    Broadcom Employee
    Posted Aug 24, 2018 05:15 PM

    Maybe this helps?

    For some out of the box domains it's not possible - CA Knowledge 

    I also found an example when the column name contains space in it

    Error in adhoc view | Jaspersoft Community 

    and some others saying a bug. If none of the suggestions here helps maybe time to open a Support case?



  • 15.  Re: Hello Everyone, i keep getting this error when i try to create a report using the adhoc view in the jasper reporting tool

    Broadcom Employee
    Posted Aug 29, 2018 04:06 AM

    This might be due to domain definition.

    Are you using sdm odbc driver or jdbc driver?

    could you share domain definition or the script you are using to create the domain ?

    are you using binary fields (uuid)? 



  • 16.  Re: Hello Everyone, i keep getting this error when i try to create a report using the adhoc view in the jasper reporting tool

    Posted Aug 29, 2018 07:13 AM
      |   view attached

    Hello,

     

    I am using jdbc driver and below in yellow is the script

     

    select count(a.id) as Total_No,b.last_name,a.status from call_req a,  ca_contact b

    where a.group_id= b.contact_uuid

    and b.contact_type=2308

    group by b.last_name,a.status

    order by b.last_name,a.status

     

    Thanks



  • 17.  Re: Hello Everyone, i keep getting this error when i try to create a report using the adhoc view in the jasper reporting tool

    Broadcom Employee
    Posted Aug 29, 2018 08:16 AM

    Hello

    I used your script to create a view in SQL like :

    create view community

    as select count(a.id) as Total_No,b.last_name,a.status from call_req a, ca_contact b

    where a.group_id= b.contact_uuid

    and b.contact_type=2308

    group by b.last_name,a.status

     

    this view is stored in SQL.

    I then created a new domain in jasper using this view

     

     

     

    in display tab specify fields to be included in your future adhoc view and adhoc report:

     

    click OK and Submit your domain.

     

    Now create an adhoc view using this domain:

     

    here is an example of your query:



  • 18.  Re: Hello Everyone, i keep getting this error when i try to create a report using the adhoc view in the jasper reporting tool

    Posted Aug 29, 2018 10:30 AM
      |   view attached

    Hello,

     

    I have seen the steps, do you mean I have to create a view because I see you modified the script?

     

    Thanks



  • 19.  Re: Hello Everyone, i keep getting this error when i try to create a report using the adhoc view in the jasper reporting tool
    Best Answer

    Broadcom Employee
    Posted Aug 29, 2018 11:39 AM

    Hi

    in fact, it sounds that jasper and domain in particular doesn't "like" binary fields like uuid. this is why you can not see all the columns in Jasper Domain.

    Creating View is one answer.

    Other answer could be to use Topics. Topics are reports developped in JasperStudio and published to jasperServer under  "topics" directory in Jasper Server.

     

    So Using jasperStudio create a new report with your query. Save it and Publish it to jasperserver under topics directory.

     

    Now you can create an Adhoc View using this topic.

    Click Create AdHoc View and you will see your topic among the list of domains available:

     

     

    I hope that help.



  • 20.  Re: Hello Everyone, i keep getting this error when i try to create a report using the adhoc view in the jasper reporting tool

    Posted Aug 29, 2018 01:57 PM
      |   view attached

    Hi,

     

    Yes creating the view solved the error message. Thank you for the assistance.

     

    Thanks



  • 21.  Re: Hello Everyone, i keep getting this error when i try to create a report using the adhoc view in the jasper reporting tool

    Posted Aug 30, 2018 11:02 AM
      |   view attached

    Hello,

     

    Thanks for the assistance earlier but I still have a challenge, I want to be able to create the report based on

    A time range like specify ‘ June 16 – June 23 ‘  because its bringing information on all incidents created.

     

    Thanks