CA Service Management

Expand all | Collapse all

support automation error

  • 1.  support automation error

    Posted 04-22-2018 05:01 PM
      |   view attached

    Hello SD Team

     

    Im getting error while initiating live chat once click continue button......what could be issue

     

     

     

     

     

     

    following is the configuration on OUR SDM HA....application server

     

     

     

    Attachment(s)

    pdf
    SA in AA Mode.pdf   313 KB 1 version


  • 2.  Re: support automation error

    Posted 04-23-2018 02:42 AM

    Looks like a name resolution issue - does the ap DNS name works from the client where the browser runs ? Try to use the FQDN instead of the short name to make sure name resolution works.



  • 3.  Re: support automation error

    Posted 04-23-2018 05:13 AM

    Are you able to reach the Support Automation URL via IP address?

     

    Are you launching this from within the SDM server or outside from an external domain?



  • 4.  Re: support automation error

    Posted 04-23-2018 01:20 PM

    Hi Brian

     

    yea i configured with IP also but the issue still same....as of now im launching within the server...

     

    pls advise



  • 5.  Re: support automation error

    Posted 04-23-2018 01:19 PM

    Hi Christi

     

    i checked with fqdn also but the issue is same



  • 6.  Re: support automation error

    Broadcom Employee
    Posted 04-23-2018 01:27 PM

    Aamir,

     

    I'm a bit confused by your setup. The screen shows that you have configured this machine as a Socket Proxy server, can you provide details of the Primary Support Automation server?



  • 7.  Re: support automation error

    Posted 04-23-2018 01:42 PM

    Hi Alex

     

    You are correct. The support automation i configured as socket proxy server. Actually we are using 17.1 sdm advance availability. and while configuring Support automation its giving 2 option as below.

     

     

     

     

    While we have also sdm 17.0 implemented in another environment. where Support automation configured successfully already....but you can see there is difference in options while configuring support automation in 17.0 as below....

     

    So wt you advise for 17.1 sdm support automation..there is no Main server option available in 17.1 configuration(in above screen shot).

     

     



  • 8.  Re: support automation error

    Broadcom Employee
    Posted 04-23-2018 01:54 PM

    Aamir,

     

    A Support Automation "Main Server" has to be deployed to a Background server in advanced availability. Without a Main server this isn't going to work at all.

     

    If you'd like the users to not connect to the Background server at all for Support Automation this can be accomplished with some manual manipulation of the server.properties files on the Support Automation servers. You can either post your server.properties files here publicly, or you can open a Support case, and provide the case number. I'll take over the case and work with you to get this configured.



  • 9.  Re: support automation error

    Posted 04-23-2018 02:17 PM

    oh ok....i thought that i need to configure app server as bg server connot be configure...

     

    anyways...let me configure standby server and then failover to bg.

     

    one thing...do i need to configure app server with support automation? 

     

    second...in option manager support automation...i will give app server url or bg server ?? 



  • 10.  Re: support automation error

    Broadcom Employee
    Posted 04-23-2018 02:22 PM

    You don't need to configure the app server for Support Automation unless you plan to have a decent amount of session traffic, and want to balance the load. If you only plan to have a limited amount of concurrent sessions you likely only need the Main server installed on the Background.

     

    If you decide to only use a Main server, the options manager url should point to the main server host. By default the Socket Proxy servers do not serve web traffic, so you want to serve web traffic some manual adjustments to the server.properties is going to be necessary to make it work.



  • 11.  Re: support automation error

    Posted 04-23-2018 02:27 PM

    Many Thanks Alex

     

    i will configure it and update.

     

    Lastly, does support automation need separate licensing to use it?



  • 12.  Re: support automation error

    Broadcom Employee
    Posted 04-23-2018 02:32 PM

    Support Automation doesn't have any separate license. The ability to authenticate is based on Service Desk's authentication and licensing.



  • 13.  Re: support automation error

    Posted 04-23-2018 02:33 PM

    ok Thanks



  • 14.  Re: support automation error

    Broadcom Employee
    Posted 04-23-2018 02:41 PM

    Hey Aamir,

     

    How do your users get to Service Desk ?  what URL?

     

    The error message indicates that  the user's browser was NOT able to get to http://ap:8070/SupportAutomation   the error seems that browser can't even resolve the URL:  AP

     

    _R



  • 15.  Re: support automation error

    Posted 04-23-2018 02:45 PM

    hi Raghu

     

    user login to application using app server url. but as explained by Alex. i

    need to configure support automation on bg server .

     

     

     

    On 23-Apr-2018 11:42 pm, "Raghu.Rudraraju" <



  • 16.  Re: support automation error

    Broadcom Employee
    Posted 04-23-2018 02:47 PM

    Raghu, the problem is that by default a socket proxy server url doesn't host the Support Automation web interface.



  • 17.  Re: support automation error

    Posted 04-24-2018 09:17 AM

    Hi Alex

     

    i failover bg server to standby server and run configure on it and enable support automation as below.

     

     

    and same thing i did on standby server by doing failover. as below config

     

     

    But still im getting same issue below....in option manager support automation url is dev-sdm-bg:8070 ....

     

    what could be issue still?? as i have already reconfigure application server and  disable the socket proxy server....

     

    pls advise

     



  • 18.  Re: support automation error

    Broadcom Employee
    Posted 04-24-2018 09:24 AM

    Aamir,

     

    It's hard to tell, please open up a Support case for additional review. You can pm me your case number, and I'll take a look.



  • 19.  Re: support automation error

    Posted 04-25-2018 07:51 AM

    Hi Alex

     

    Hi Alex i have opened a case and the consultant shared the following link to configure SA in AA. i also have attache pdf here in my post.

     

    https://communities.ca.com/message/241814406#241814406

     

    if you see in screenshot below ...the parameter should be like this in nx file but the highlighted one is not the same in my nx file.

     

     

    this is wt i have in my nx file ...below...it didnt update while doing from option manager....even after recycle service. can you advise....or should i share case number ...i didnt find inbox option in your profile

     



  • 20.  Re: support automation error

    Broadcom Employee
    Posted 04-25-2018 08:32 AM

    Aamir..........

     

    Looks like you are working on this via CA Support case #01070242.

     

    I am sure that Alex Perretti will work with the CA Support engineer assigned to the CA Support case to help resolve the issue.



  • 21.  Re: support automation error

    Posted 04-25-2018 08:43 AM

    many thanks

     

    On 25-Apr-2018 5:32 pm, "Paul_Coccimiglio" <