CA Service Management

Expand all | Collapse all

Blank report screen when clicking on report tab in SDM. How Fix it?

Jump to Best Answer
  • 1.  Blank report screen when clicking on report tab in SDM. How Fix it?

    Posted 12-14-2017 11:09 AM

    If I click on the Reports tab and the screen stays like this:

    But, when clicking on the BI Launch Pad button the BO interface opens:

     

    How i can fix this ?

     

    Environment: Windows

    SDM 14.1 with cum 2

    CABI 4.1



  • 2.  Re: Blank report screen when clicking on report tab in SDM. How Fix it?

    Broadcom Employee
    Posted 12-14-2017 11:20 AM

    Albino......

     

    Did the SDM Reports tab ever work before?  If so, any recent changes to the SDM environment?

     

    When the BI LaunchPad button is clicked, does another web browser window open and the user logged into CABI with their account (check the right hand corner of the screen for logged in user information)



  • 3.  Re: Blank report screen when clicking on report tab in SDM. How Fix it?

    Posted 12-14-2017 12:22 PM

    Paul,

     

    The Reports tab crashed after SDM uninstall / install. So I did the steps to integrate them.

     

    The CABI window opens logged with the same user that i had logged in SDM (usr_caitsm).

    Trusted authentication is configured and the SDM user exists on CMC.



  • 4.  Re: Blank report screen when clicking on report tab in SDM. How Fix it?
    Best Answer

    Broadcom Employee
    Posted 12-14-2017 11:39 AM

    Hey Albino,

     

    This can be caused by a number of issues, depending on your answer to Paul's earlier question of clicking BI Launch Pad:

     

    If you click BI Launch Pad button and it takes you directly to BI Launch Pad page prompting you to log in:

     

    -User Specific: If this issue happens for only specific users, you can confirm if their contact record exists in the Central Management Console -> Users and Groups. If they do not exist here, add a new contact record and ensure that the username and password are an exact match to the username and password that user logs in to SDM with.

     

    If you are taken to the BI LaunchPad page already logged in, it can relate to your IIS string/query length:

     

    -Modify the maxQueryString to 3000 by opening up the web.config file on your servers from the following location:

     

    NXRoot/bopcfg/wwwroot

     

    and then look for the following and adjust it to 3000:

     

    <security>

    <requestFiltering>

    <requestLimits maxQueryString="3000" maxUrl="3000" />

    </requestFiltering>

    </security>

     

    Finally, just run an iisreset.

     

    If none of these solve your issue, i'd recommend opening a support case, as BOXI issues sometimes require additional troubleshooting steps.

     

    Regards, 

    Brandon Persad



  • 5.  Re: Blank report screen when clicking on report tab in SDM. How Fix it?

    Posted 12-14-2017 12:40 PM
      |   view attached

    I get to the BI LaunchPad page that is logged in

     

    web.config file does not exist in

    NXRoot / bopcfg / wwwroot,
    it is in this path:

    NXRoot / bopcfg / www / wwwroot


    But the mentioned entry is not found

    Attachment(s)

    zip
    web.config.zip   288B 1 version


  • 6.  Re: Blank report screen when clicking on report tab in SDM. How Fix it?

    Broadcom Employee
    Posted 12-14-2017 01:00 PM

    Within the NXROOT\bopcfg\www\wwwroot \web.config file you will need to add the following entry as indicated by perbr08

     

    <security> 
    <requestFiltering> 
    <requestLimits maxQueryString="3000" maxUrl="3000" /> 
    </requestFiltering> 
    </security> 

     

    You will then need to recycle the IIS service for the change to take effect.



  • 7.  Re: Blank report screen when clicking on report tab in SDM. How Fix it?

    Broadcom Employee
    Posted 12-14-2017 02:29 PM

    Yeah, I apologize for that typo in the path name. You can just add that entry and recycle IIS.



  • 8.  Re: Blank report screen when clicking on report tab in SDM. How Fix it?

    Posted 12-15-2017 01:51 PM

    After applying the suggested change, other errors appeared, but I managed to overcome all of them by searching the knowledge base.

     

    Many thanks!



  • 9.  Re: Blank report screen when clicking on report tab in SDM. How Fix it?

    Broadcom Employee
    Posted 12-14-2017 01:31 PM

    Hi Albino,

    1/ on the servicedesk page upper right I see a key. Do you confirm your sdm is in SSL ?

    2/ on the launchpad page, the port is 8080 , often not SSL

     

    If you confirm you have servicedesk in SSL mode and not boxi, you may be in this situation.

     

    SSL application (SDM) including non ssl page (BOXI) , content is blocked by the browser. Check if you are in the case of this tecdoc

    https://support.ca.com/us/knowledge-base-articles.TEC1283659.html

    After enabled SSL in Tomcat for CA Service Desk Manager, report tab show blank/white screen.

     

    Best regards,

    Chris