CA Service Management

Expand all | Collapse all

Cannot populate custom fields in SDM.

Jump to Best Answer
  • 1.  Cannot populate custom fields in SDM.

    Posted 02-28-2018 06:32 AM
      |   view attached

    Using wsp, i have created three fields on factory Org:
    z_srl_sdmAlgar SREL > cnt.id
    z_dte_contractExpiration DATE
    z_str_ctrNum STRING

     

    Following these steps:
    1 - invoke pdm_wsp on SDM background server
    2 - add columns
    3 - save and publish
    4 - perform failover changing background to standby server
    5 - run pdm_publish on original background server
    6 - restart background server
    7 - perform failover again
    8 - restart each application server

     

    Well, at this moment the table usp_organization on DBMS present these fields, like when i run the command "bop_sinfo -d org". But, when i try to load values the pdm_userload ignores these fields informing that they does not exist.

     

    When i run a pdm_extract command these fields do not exported also.

     

    Runing "bop_sinfo -qd org" i noticed that these fields have a different characteristic, all of them have "<>" foward the name. Does this mean anything?

     

    How can in solve this problem?

     

         ****These values presented here was inserted via sql server update.

    Attachment(s)



  • 2.  Re: Cannot populate custom fields in SDM.
    Best Answer

    Posted 02-28-2018 09:00 AM

    Hi Albino,

    I am guessing that most likely you did not suppress version control somewhere in the process, so some of the files, possibly ddict, wsp.mods, etc. may have gotten rogue versions (without your new fields) pushed out by the standby server when you promoted it to be the background.  What I would do is stop services on the entire environment and compare the following files on all servers:

    wsp.mods

    wsp_schema.sch

    ddict.sch

    You can also use a tool search tool such as "agent randsack" ( a great freebie) to search for the names of your custom fields in the entire site directory on each server, and ensure that they appear in the appropriate files.

    Once you are sure you have the correct versions of the files on all servers, start the system back up.

    You can find the documentation with the appropriate steps for the future here:  How to Modify Schema Using Web Screen Painter - CA Service Management - 17.0 - CA Technologies Documentation 

     

    Hope this helps,

    Thanks

    Jon I.



  • 3.  Re: Cannot populate custom fields in SDM.

    Posted 02-28-2018 06:22 PM

    I had perform a fake commit and followed the guidelines in the document you mentioned and managed to resolve the issue.



  • 4.  Re: Cannot populate custom fields in SDM.

    Broadcom Employee
    Posted 02-28-2018 09:24 AM

    Albino, I think you may have some hidden chars in the attribute names. For now, SDM may have attributes like "z_srl_sdmAlgar <>" not "z_srl_sdmAlgar" as you wanted. You may want to manually modify the related files to correct this to make it z_srl_sdmAlgar. Thanks _Chi



  • 5.  Re: Cannot populate custom fields in SDM.

    Broadcom Employee
    Posted 03-01-2018 09:01 AM

    Albino,

     

    Just a comment that there is a document about making schema changes using WSP, where it also mentions the version control supression at step 2:

     

    How to Perform Schema Changes using Web Screen Pai - CA Knowledge 

     

    ....

    2 . Run the command ‘pdm_server_control -v’ from Command Prompt to suppress the version control on the Background server

     

    Regards,

    Roberto