CA Service Management

Expand all | Collapse all

inactivate CI in CMDB

Jump to Best Answer
  • 1.  inactivate CI in CMDB

    Posted 12-20-2017 01:24 AM

    Hi Folks,

     

        We are trying to inactivate our CI in CMDB through SDM GUI. After inactivating It is showing that records has been updated successfully. But again when we are opening the record its showing as active only.

    The records which we are trying to update is discovered from the spectrum. 

     

    Can anyone let me know why this is happening or what I am doing wrong.

     

    Thanks in Advance,

    EMS



  • 2.  Re: inactivate CI in CMDB

    Posted 12-20-2017 03:46 AM

    Hi EMS,

     

    If you go to the audit history (Versioning tab) of the CI, can you see in the timeline when you updated it to inactive and who\what makes it active again? Perhaps this could help to figure out if Spectrum is the one responsible for updating these CIs on a regular basis.

     

    ===

    Kind Regards,

    Brian



  • 3.  Re: inactivate CI in CMDB

    Posted 12-20-2017 05:01 AM

    Thanks Brian for your reply,

     

        I checked in versioning tab also. There I can see only the inactivation detail only. No activation details are there. But CI is active.

     

    Apart from this in CA SDM standard log I am getting some DB related error.

    I don't know if CMDB can be able to inactivate the CI's which are created from spectrum.

     

    Thanks & Regards,

    EMS



  • 4.  Re: inactivate CI in CMDB

    Posted 12-20-2017 06:14 AM

    Hi EMS,

     

    What happens if you try same with GRLoader?

     

    Can you share the error message you seem to see in the logs?

     

    ===

    Kind Regards,

    Brian



  • 5.  Re: inactivate CI in CMDB

    Posted 12-20-2017 10:22 AM

    EMS, what was the "some DB related error"? Something in stdlog as well? Thanks _Chi



  • 6.  Re: inactivate CI in CMDB

    Posted 12-20-2017 08:16 AM

    Is your error message looking similar to : :[Microsoft OLE DB Provider for SQL Server] [ SQL Code=650 SQL State=42000] You can only specify the READPAST lock in the READ COMMITTED or REPEATABLE READ isolation levels.



  • 7.  Re: inactivate CI in CMDB

    Posted 12-20-2017 08:36 AM

    Hi EMS,

    I am wondering if what you are seeing in the GUI is cached and the CI is actually inactive.  Have you checked the database after making the change to see if its actually showing as active or inactive on the database side?

    Jon



  • 8.  Re: inactivate CI in CMDB

    Posted 12-20-2017 09:04 AM

    Good point Jon.

     

    A 'pdm_webcache -H' and clearing of the browser cache can also verify if the issue is with the cache or not.



  • 9.  Re: inactivate CI in CMDB

    Posted 12-20-2017 09:53 AM

    Hi EMS,
    Is the error in the std log like the one Pier-Oliveier Tremblay mentioned?
    If not, can you please post the error?



  • 10.  Re: inactivate CI in CMDB

    Posted 12-26-2017 02:20 AM

    Hi All,

     

     Sorry for the delay response. I was on leave, so could not be able to reply.

     Today also I tried the same thing. I cleared the cache as well. Checked in database also.

    In db its showing active only. Every time we are making it inactive from SDM side and when we go for search again its coming as active CI.

    Today I am not able to find the db error also in log files.

     

    Thanks and Regards,

    Vikash



  • 11.  Re: inactivate CI in CMDB

    Posted 12-28-2017 03:01 PM

    Can you confirm that only the entries discovered by Spectrum are not allowing inactivation?  Are any CI's allowing for inactivation?

     

    A case may be necessary to proceed further.  My thought would be to run additional logging to see if the SQL command is even registering to update the entry for its active flag/field correctly. However, further logging analysis and troubleshooting may best be handled in a case.



  • 12.  Re: inactivate CI in CMDB

    Posted 12-29-2017 05:19 AM

    I agree with David. We need a formal case logged and proper investigation and\or tracing be done, considering we do not see an audit of the CI being made active again in the Versioning Tab. 

     

    I suspect there could be a direct database trigger update or custom method not going via the object later that is setting the field back to active. 



  • 13.  Re: inactivate CI in CMDB
    Best Answer

    Posted 01-01-2018 03:28 AM

    Thank you all,

     

      I also think that I need to create a support case to find the root cause. So I am going to create a support case for the same. Thank you all for your effort.

     

    Thanks & Regards,

    Vikash Sonar



  • 14.  Re: inactivate CI in CMDB

    Posted 01-08-2018 03:59 AM

    Care to supply us with the case number so some of us can track it internally?

     

    Please also share the resolution and\or rootcause with the rest of us once the case is resolved.

     

    ===

    Kind Regards,

    Brian



  • 15.  Re: inactivate CI in CMDB

    Posted 02-13-2018 10:50 PM

    Hi All,

     

        FYI..

    Case Number.  

    00923381

     

    Solution:  https://support.ca.com/us/knowledge-base-articles.TEC1725392.html

             https://communities.ca.com/docs/DOC-231166539

     

    As we had ITAM integrated with SDM. So CA suggested us to install cum patch to fix the issue. Above is the link which can explain more.

     

    Thanks & Regards,

    Vikash Sonar