CA Service Management

Expand all | Collapse all

Unable to access hostname:9002 (xFlow URL) from local system

  • 1.  Unable to access hostname:9002 (xFlow URL) from local system

    Posted 06-15-2017 02:31 AM

    Hi Team,

     

    I am unable to Unable to access hostname:9002 (xFlow URL) from my local system though I am able to access it from my SDM servers.we are able to telnet port 9002 from my local system.we also uploading good and badcases fiddler traces.

     

    Attachment(s)

    zip
    goodcases.saz.zip   80K 1 version
    zip
    baddcase.saz.zip   48K 1 version


  • 2.  Re: Unable to access hostname:9002 (xFlow URL) from local system

    Posted 06-15-2017 07:57 AM

    Ravi,

    Does this happen to any machine outside of the server itself?  Or is it working on other people's machines, just not yours?    Also from the screenshot it looks like fiddler shows it accessing port 9004 - so make sure that port is open as well.

    Jon



  • 3.  Re: Unable to access hostname:9002 (xFlow URL) from local system

    Broadcom Employee
    Posted 06-15-2017 10:17 AM

    hey Ravi,

     

    The issue seems to be around DNS resolution.  The error in browser states that the browser machine is not able to resolve the hostname you have typed.

     

    With in xFlow's server, there's config file that would have the hostnames. Maybe they need to be changed to FQDNs that your browser can resolve?

     

    • For IIS server: Navigate to <xflow_install_location>\ APPS\UI\Apache24\htdocs\conf folder and edit the casm.conf.js file.
    • For Apache: Navigate to <xflow_install_location>\ APPS\UI\Apache24\htdocs\conf\ and edit the casm.conf.do-not-change.js file.

     

    config: {
    api : {
    server : 'http://xFlowHostName:9004'

    },
    search : {
    server : 'http://xFlowHostName:9006'
    },
    sdm : {
    server : 'http://SDMHostName:8080/CAisd/pdmweb.exe' // - example:http://sdmurl:8080/CAisd/pdmweb.exe
    },
    websocket : {
    server : 'ws://xFlowHostName:9008'
    },
    locale:'en-US'

     

     

     

    Change them to correct FQDNs that your browser can resolve.

     

    Restart xFlow and retest

     

    _R



  • 4.  Re: Unable to access hostname:9002 (xFlow URL) from local system

    Posted 06-16-2017 09:12 AM

    Hey Ravi,

     

    Did you get a chance to make the changes recommended by Raghu.Rudraraju ?

     

    Regards

    Junaid



  • 5.  Re: Unable to access hostname:9002 (xFlow URL) from local system

    Broadcom Employee
    Posted 07-05-2017 06:35 AM

    Hi Junaid,

     

    Please check the cors configuration file for the cross origin settings. 

     

    You can check in the following files:

    C:\Program Files\CA\xFlow\APPS\Services\incidentmicroservice-0.1-SNAPSHOT\conf\application.conf
    C:\Program Files\CA\xFlow\APPS\Services\pushmicroservice-0.1-SNAPSHOT\conf\application.conf
    C:\Program Files\CA\xFlow\APPS\Services\searchmicroservice-0.1-SNAPSHOT\conf\application.conf

     

    OOB this value is as:

     

    # The allowed origins. If null, all origins are allowed.
    //allowedOrigins = ["http://host1","http://host2"]
    play.filters.cors.allowedOrigins = null       

     

    Please check if customer did any changes to this, if so you have to revert it and restart xFlow services.

     

    Hope this hellps.

     

    Thanks & Regards,

    Hema.