Clarity Service Management

Expand all | Collapse all

Failed to launch installer in RHEL 6 64-bit

Jump to Best Answer
  • 1.  Failed to launch installer in RHEL 6 64-bit

    Posted 12-13-2017 11:26 AM

    I'm trying to install SDM 12.9 in RHEL 6, 64-bit, but the installer itself is not launching. I'm getting the following error when trying to execute setup.sh1:

     

    " Unable to locate the application's 'main' class. The class 'com.ca.ServicePlus.DVDMenu.SDMenuPane' must be public and have a 'public static void main(String[])' method. (LAX)
    Unable to Launch Java Application: Unable to locate the application's 'main' class. The class 'com.ca.ServicePlus.DVDMenu.SDMenuPane' must be public and have a 'public static void main(String[])' method. (LAX) "

     

    I found a solution document in CA, but it is for RHEL 5 and lower version of java:

     

    https://support.ca.com/us/download-center/solution-detail.html?docid=520596&os=REDHAT-5&aparno=RI18123#

     

    The java version it suggest is not the latest version:

     

    "java-1.4.2-gcj-compat-1.4.2.0-40jpp.115
    java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp.115
    java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp.115
    java-1.4.2-gcj-compat-src-1.4.2.0-40jpp.115 "

     

    What would be the latest java version I can use to be able to launch this installer without any issues? I believe we currently have 1.8.0.



  • 2.  Re: Failed to launch installer in RHEL 6 64-bit

    Posted 12-13-2017 03:22 PM

    Hi Marc,

     

    Maybe its one of the missing 32 bit packages that we need.

     

    This is a sample that I use sometimes to prep some of our boxes from internal repos.  Maybe it'll work for you too?

     

    echo yes | yum install libXp.i686
    echo yes | yum install libXtst.i686
    echo yes | yum install openssl.i686
    echo yes | yum install openldap.i686
    echo yes | yum install pam.i686
    echo yes | yum install pcre.i686
    echo yes | yum install libuuid.i686
    echo yes | yum install libXrender.i686

    echo yes | yum install libXext.i686

     

    _R



  • 3.  Re: Failed to launch installer in RHEL 6 64-bit

    Posted 12-13-2017 04:15 PM

    oops, the screen did not refresh on my first reply, so posted again.  Sorry about that, it shows up twice now

     

    _R



  • 4.  Re: Failed to launch installer in RHEL 6 64-bit
    Best Answer

    Posted 12-13-2017 03:37 PM

    Hey Marc,

     

    12.9 was built using rather old java libraries. 

     

    Maybe try something like this that I use on some of our internal installs ?  

     

    echo yes | yum install libXp.i686
    echo yes | yum install libXtst.i686
    echo yes | yum install openssl.i686
    echo yes | yum install openldap.i686
    echo yes | yum install pam.i686
    echo yes | yum install pcre.i686
    echo yes | yum install libuuid.i686
    echo yes | yum install java-1.5.0-gcj.i686
    echo yes | yum install libXrender.i686

    echo yes | yum install libXext.i686

     

    Hope this helps

    _R



  • 5.  Re: Failed to launch installer in RHEL 6 64-bit

    Posted 12-14-2017 10:07 AM

    Thanks Raghu.Rudraraju!

     

    We were missing the 1.5.0-gcj and libXrender. Worked fine after installing all of these.