Clarity Service Management

Expand all | Collapse all

Knowledge Documents Not Inheriting Permissions From Sub-Categories

  • 1.  Knowledge Documents Not Inheriting Permissions From Sub-Categories

    Posted 02-10-2017 11:27 AM

    Here's our issue:

    A knowledge document is created and with category A as the primary category. Both the knowledge document and the category are set to inherit permissions from parent.

    We then add additional sub-categories to this knowledge document with their own sets of permissions that are inherited from their respective parent group.

     

    This leaves us with a knowledge document that has a "primary" category and a few additional categories.

     

    The problem is that the knowledge document only ever inherits permissions from the "primary" category. None of the permissions from any of the sub-categories are added onto the knowledge document. This is a problem because we control viewership of knowledge documents based on the category(s) in which the document resides (each category has certain groups of employees assigned to it). So if the knowledge document is only pulling inherited permissions from one of the categories it's located in, then the people in the other categories are never able to see these knowledge documents. 

     

    Is this expected behavior or is there a setting somewhere to allow a knowledge document to inherit permissions from multiple categories? If this IS expected behavior, then how can I allow different groups access to the same document(s) without manually editing the permission on ever single knowledge document that is created? That would get very tedious.

     

    Thanks!



  • 2.  Re: Knowledge Documents Not Inheriting Permissions From Sub-Categories

    Posted 02-20-2017 11:02 AM

    Mitchell........

     

    Please try changing the Permission option of the sub category to "Specify categorypermissions", save it, and set the permission to "Inherit permissions from parent category" again and see if the KT document permissions are set correctly