CA Service Management

Expand all | Collapse all

CA SDM 17.0 Installation Failed

Jump to Best Answer
  • 1.  CA SDM 17.0 Installation Failed

    Posted 09-01-2017 04:44 PM
      |   view attached

    Hi everyone,

     

    I'm trying to install SDM 17.0 in a fresh server (AA architecture, background server). However, for some unknown motive, the wizard is not registering pdm_daemon_manager as a Windows server. As a result, the install is failing in the autointegration stage, when it needs to check if slump server is running.

     

    The strange thing is, ODBC Agent and ODBC Data Access are being registered as Windows services without errors. I've already tried to run pdm_d_mgr standalone, without success.

     

    What can be causing the wizard for not registering pdm_daemon_manager? I'm attaching install.log, if you are interested.

     

    Thanks,

     

    Diogo

    Attachment(s)

    zip
    install.log.zip   57 KB 1 version


  • 2.  Re: CA SDM 17.0 Installation Failed

    Posted 09-02-2017 01:17 PM

    Hi Diogo,

    The service is installed when the first pdm_confiugure is completed after installation is finished (which occurs automatically - you dont see it on the screen its done silently in the background I believe).  So most likely this means that the first pdm_configure did not complete properly.  So we would want to see both the install log, as well as the configure log if there is one - and any stdlogs that were generated.

    Let us know,

    Thanks,

    Jon I.



  • 3.  Re: CA SDM 17.0 Installation Failed

    Posted 09-04-2017 09:14 AM

    Hi Jon_Israel,

     

    I'll check configure.log files, thanks for the tip. And about stdlog files, I think it won't be any help, I already looked for it and it has not much significant messages, since pdm_daemon_manager is not being even executed.

     

    Thanks,

     

    Diogo



  • 4.  Re: CA SDM 17.0 Installation Failed
    Best Answer

    Broadcom Employee
    Posted 09-03-2017 10:30 PM

    This recently happened to me with a clean install against SQL 2016.  Look in configure.log and you may see near the end that sql_check_db failed to connect to the database.  In my case the connection issue was resolved by uninstalling the SQL 2016 ODBC drivers and Command-Line utilities (V13), installing the latest release of the SQL 2012 'Native Client' JDBC and ODBC drivers and Command-Line utilities (V11), as pointed to by TEC1816438, and re-running the install.

     

    Regards,

    James



  • 5.  Re: CA SDM 17.0 Installation Failed

    Posted 09-04-2017 09:11 AM

    Hi camja06,

     

    Yeah, I think I noticed some sort of DB error in install.log file, but since the wizard created MDB successfully, I thought the error was in somewhere else. I'll try to use these releases of JDBC and ODBC drivers, but are these really compatible with SQL Server 2016?

     

    One more thing, I couldn't find this TEC1816438, could you send me a link for it?

     

    Thanks,

     

    Diogo



  • 6.  Re: CA SDM 17.0 Installation Failed

    Broadcom Employee
    Posted 09-04-2017 10:06 AM

    Hi Diogo,

     

    Hope you looing for this document link : https://support.ca.com/us/knowledge-base-articles.tec1816438.html



  • 7.  Re: CA SDM 17.0 Installation Failed

    Broadcom Employee
    Posted 09-04-2017 10:45 PM

    I can't speak authoritatively for Microsoft, obviously, but on the download page for the SQL Server Native Client pointed to by TEC1816438 (thanks to Maheshwar for the link) this statement appears:

      Note that Microsoft will not be releasing a SQL Server 2014 or later version of the SQL Server Native Client. The SQL Server 2012 Native Client (v11, e.g. sqlncli11.dll), can continue to be utilized by SQL Server 2014 and later versions.

     

    Regards,

    James



  • 8.  Re: CA SDM 17.0 Installation Failed

    Posted 09-05-2017 08:50 AM

    Yeah, I didn't understand this part. I believe the issue was in the "forced TLS 1.2" in V13.

     

    But, at least, when I used V11, the installation worked perfectly, without errors! I wish this could be better documented in the install guide, so other people would not have problems in implementation.

     

    I've installed these packages, in this order:

     

    1. Download Microsoft® SQL Server® 2012 Native Client - QFE from Official Microsoft Download Center 
    2. Download Microsoft® ODBC Driver 11 for SQL Server® - Windows from Official Microsoft Download Center 
    3. Download Microsoft® Command Line Utilities 11 for SQL Server® from Official Microsoft Download Center 

     

    camja06, thanks for the tip!

     

    Regards,

     

    Diogo