CA Service Management

Expand all | Collapse all

Can not find Request with 'Search' function, works with link from e-mail

Jump to Best Answer
  • 1.  Can not find Request with 'Search' function, works with link from e-mail

    Posted 12-13-2016 07:42 AM

    I have a question about searching and viewing requests.

     

    I've experienced a few times that when a request is submitted in the catalog, the request can't be found when I search the request ID using the search function in the catalog.

     

    Although, if I use the link from the notification e-mail that was sent when the request was submitted/approved/fulfilled, the request is found. I can see the request data in db-table usm_request. 

     

    I can also find the request by simply searching for another request, view it, and change the requestID in the URL to the requestID which I can't find the normal way. 

    /.. Node=icguinode.requestprofile&Args=173169 .. /

     

    Does anyone know why? I've seen this in both version 12.9 and 14.1 

     

    /Karolin



  • 2.  Re: Can not find Request with 'Search' function, works with link from e-mail

    Posted 12-13-2016 05:20 PM

    I know there are a number of checks (including validating req for/by users and approvers/fulfillers) when you search for requests. I would suggest searching again, noting the time you select Go/Search, and check ..\Service Catalog\logs\error.log for any errors/exceptions at that time. If there is nothing related in the error.log I would recommend increasing the log level to TRACE on the view.log and repeat the above steps. You can increase the log level on view.log by updating line 26 of ..\Service Catalog\view\conf\log4j.xml to 'TRACE' as follows:

     

    <appender name="view" class="org.apache.log4j.RollingFileAppender">
    <param name="File" value="${usm.home}/logs/view.log" />
    <param name="MaxFileSize" value="20MB" />
    <param name="MaxBackupIndex" value="100" />
    <param name="Threshold" value="TRACE" />

     

    If this is specific to requests raised by/for a particular user or approver/fulfiller I would also suggest checking the ca_contact for duplicate records. We have seen some odd behavior when there are duplicate records with the same userid even when only 1 is active (i.e. inactive=0).



  • 3.  Re: Can not find Request with 'Search' function, works with link from e-mail
    Best Answer

    Posted 12-14-2016 04:00 AM

    Thank you very much Jason. It was indeed the req_for_user_id that was set to inactive. When i set the inactive flag to 0, I was able to find the request via the search function as normal. 

     

    Have a good day!

    Karolin Albinsson



  • 4.  Re: Can not find Request with 'Search' function, works with link from e-mail

    Posted 12-14-2016 04:00 AM

    Thank you for the input, Louis!

    /Karolin Albinsson



  • 5.  Re: Can not find Request with 'Search' function, works with link from e-mail

    Broadcom Employee
    Posted 12-14-2016 01:59 AM

    Another possiblt help could be the following.
     
    It explains how to be able to find request(s) with an inactive user.
    Once found, you can then decide how to further process that request.
     
    Regarding Advance search:
    You can use the advance search feature to construct the search condition to find the requests whose request_for or request_by are inactive.
     
    Please also check this tecdoc:
    http://www.ca.com/us/services-support/ca-support/ca-support-online/knowledge-base-articles.tec1732245.html
     
    In the dropdown, it has "Request For User Status" (also "Request By User Status").
    In your search, you can use it and set it as inactive in the search condition to find the requests that you want.
     
    The above is only an example. To be used depending on any other qiery you might have.

     

    Thanks and kind regards, Louis van Amelsfort.



  • 6.  Re: Can not find Request with 'Search' function, works with link from e-mail

    Posted 12-15-2016 04:35 AM

    Hi,

     

    We have same behaviour in our environment, we see such issue when user in ca_contact is inactive. If you active them you will be able to see the request. if any request is not found its always good to check requested for or requested by or approver is active. you can activate the contact for a while and perform required action and then inactive it.