Clarity Service Management

Expand all | Collapse all

Mail configuration, not autheticated...?

  • 1.  Mail configuration, not autheticated...?

    Posted 02-10-2017 09:35 AM

    Hello vibrant community, 

     

    I am having an issue with the Mail configuration of Service Catalog. I have tried entering the hostname and the ip address of the email server. The user used for authentication can logon to the server and send email to itself. Furthermore, I have tried adjusting these settings through the common component configuration. 

    With and without TLS, and different TLS levels. 

     

    Is there a link to the description of the TLS levels for SC. (found the ones for SDM).

     

    Look in the attachments too see the error from view.log and current configuration of mail server. 

     

    Any help is appriciated! 

     

    BR,

    Sondre. 

     

    #email #sc #integration #ca #mail #request



  • 2.  Re: Mail configuration, not autheticated...?

    Posted 02-10-2017 10:33 AM

    Hi Sondre,

     

    If I may assume the Catalog version is on 14.1, Catalog does not currently support TLS for email. Catalog always sends anonymous emails and will not login through TLS. This may lead up to opening an enhancement with CA
    Are you able to to test the email setup without the TLS configuration?


  • 3.  Re: Mail configuration, not autheticated...?

    Posted 02-11-2017 07:52 AM

    Hi, 

     

    Yes, we are running the 14.1 version of the Catalog.

     

    I followed your tip, and removed the TLS and ran the component integration again, restarted the services. Still same result. 

     

    "The email address entered is invalid, please correct the email address and try again"

     

    This should be rather simple... ?? 



  • 4.  Re: Mail configuration, not autheticated...?

    Posted 02-13-2017 01:51 AM

    Good Morning Sondre.

     

    The message "The email address entered is invalid, please correct the email address and try again" could be caused by an invaid(or none) email address set in:

    SC/Catalog/Configuration/RequestManagementConfig and then the "Request Email: From Address" propery.

     

    Please check on that and let us know your findings.

     

    Kind regards, Louis van Amelsfort.



  • 5.  Re: Mail configuration, not autheticated...?

    Posted 02-13-2017 04:08 AM

    Hi, 

     

    I have set the from property of the "from adress" to the email address of the user I have used for autentication in the Mail Server settings. These settings should result in this user sending an email to itself. Still same problem. 

     

    However, we are now planning another solution, where SDM and PAM takes care of all email interactions(since SC does not support TLS).

     

    What we want, is for user to recieve emails whenever they submit a request in SC, and whenever their requests gets resolved. If the corrospoding request in SDM contains an external ticket ID, an email will be sent (with link to the catalog). If it does not contain an external ticket id, a regular email will be sent. 

     

    Also we are planning for PAM to send approvals through email, where the approver is prompted through a form, or linked directly to the catalog.

     

    Do you guys forsee any limitations or potential problems with this setup?

     

    Thanks for all the answers. 

     

    BR, 

    Sondre.