CA Service Management

 View Only
  • 1.  CA SDM Installation Error

    Posted Jan 21, 2017 08:05 AM
      |   view attached

    Hi everybody! 


    I'm facing a problem during the installation of SDM, as I can see from the wizard it seems to fail with steps "Installing CA Service Desk Manager Database Schema Remotely" and "Configuring CA Service Desk Manager". 

    SDM Installation Error


    The database server is in other server and there're no firewalls, so it's not a connectivity problem. 


    I already tried with no luck: 

    - Restart the SDM and DB server.

    - Download another DVD media from the server and an installation repair.


    I'll attach the complete log files. 


    Any help will be appreciated.



    zip   19 KB 1 version

  • 2.  Re: CA SDM Installation Error

    Posted Jan 21, 2017 09:21 AM

    Hi InfiniteLoop

    If you observe the configure.log ,you can see that setupmdb.bat file is missing.

    01/19 13:43:27.069 INFO 168 setting SQL DB admin user:sa and password:<password>
    01/19 13:43:27.069 INFO ? ? Starting Setup MDB...
    01/19 13:43:27.069 INFO ? ? The command is "C:\PROGRA~2\CA\SERVIC~1\add-ons\mdb\mssql\setupmdb.bat" -DBVENDOR=mssql -DBDRIVER=Service_Desk -WORKSPACE=Service_Desk -DBHOST=SDMDBGYE02 -DBNAME=mdb -DBPORT=1433 -DBUSER=sa -DBPASSWORD=<SYS PASSWORD> -JRE_DIR="C:\Program Files (x86)\CA\SC\JRE\1.7.0_10" -MDB_TARGET_DIR="C:\PROGRA~2\CA\SERVIC~1\temp\mdb_sql" -MDB_COMMON_DIR="C:\Program Files\CA\SC\Mdb"
    01/19 13:43:27.069 INFO ? ? Executing command: "C:\PROGRA~2\CA\SERVIC~1\add-ons\mdb\mssql\setupmdb.bat" -DBVENDOR=mssql -DBDRIVER=Service_Desk -WORKSPACE=Service_Desk -DBHOST=SDMDBGYE02 -DBNAME=mdb -DBPORT=1433 -DBUSER=sa -DBPASSWORD=<SYS PASSWORD> -JRE_DIR="C:\Program Files (x86)\CA\SC\JRE\1.7.0_10" -MDB_TARGET_DIR="C:\PROGRA~2\CA\SERVIC~1\temp\mdb_sql" -MDB_COMMON_DIR="C:\Program Files\CA\SC\Mdb"
    01/19 13:43:27.082 INFO ? ? The system cannot find the file specified.
    01/19 13:43:27.334 INFO ? ? Process "C:\PROGRA~2\CA\SERVIC~1\add-ons\mdb\mssql\setupmdb.bat" completed with exit code 1
    01/19 13:43:27.334 ERROR ? ? Setup MDB returns code 1


    # could please try to run pdm_configure -z and upload the configure.log again.

    # Also please confirm if you have the SQL Client installed on SDM server? If so, is it the correct SQL client for the version of SQL they are using on the DB side?


  • 3.  Re: CA SDM Installation Error

    Posted Jan 21, 2017 04:42 PM

    Hi Junaid,


    Regarding of the questions: 

    1) I tried to run pdm_configure -z but after the database screen the wizard says that "Can not connecto to mdb database on server":

    Error db


    2) Yes, I installed the SQL Client with the same DVD media as used on the db server.


    It's normal the error and I should continue with the wizard? 






    I selected "Load Default Data" and let me continue; but it still fails when completing the "Configure MS SQL Server" step.

    Error pdm_configure


    I'll attach the log files again.



  • 4.  Re: CA SDM Installation Error

    Posted Jan 21, 2017 11:44 PM

    Hey InfiniteLoop

    If you see the screenshot which you attached , SDM server is unable to connect to mdb database.


    # Firstly I would suggest you to check the path to the SQL Client tools if it missing from the Operating System's path (e.g. "C:\Program Files\Microsoft\SQL Server\100\Tools\Binn") and thwn reboot the server.


    # Now again try to run pdm_configure.


    # Also check that you enabled 8.3 File notation on all volumes in the SDM server.
    If not then please enable enable 8.3 File notation following the below document and then give a try.


  • 5.  Re: CA SDM Installation Error

    Posted Jan 22, 2017 10:25 AM

    Hi Juanid! 


    I checked what you told me and:


    1) Yes, there are many paths ("Program Files (x86)" and "Program Files") to the SQL Client on the Operating System's path.


    2) The wizard still said it can't connect to the db.


    3) It wasn't enabled, I followed the instructions in the link and restarted the servers (sdm and db); but still the message is saying it can't connect to the db.


    I started checking the communication ports when running the wizard and found something strange:


    Everytime the wizard tells me that "Can't connect to the database mdb", the sdm server tries to communicate using a "[System Process]" to the db server without luck; but as you can see the port isn't closed, because I have the SQL Tools open and connected at the time I ran the wizard.




  • 6.  Re: CA SDM Installation Error

    Posted Jan 22, 2017 05:17 PM

    HI InfiniteLoop ,


    You need to check.


    A. Connectivity

    B. Tools



    A. Connectivity

    A. 01. ping?

    A. 02. telnet?

    A. 03. Can you connect using the MS SQL?  Troubleshooting Connectivity  



    B.01. Try to connect using SupportArmyKnife1.3.jar  by Shawn_Walsh 

    B.01. You need the MS SQL Tools - osql Utility 



    Tiago Macul


    Know more, visit:

    Summary CA ITAM 

    Service Desk Manager 15 days Implementation 


  • 7.  Re: CA SDM Installation Error
    Best Answer

    Posted Jan 23, 2017 12:41 AM

    Thanks for your answer Tiago,


    I found what was the reason of the issue. I had already tested connectivity (ping, telnet and SQL Tools), and the .jar tool also returns possitive results; but the wizard still fails. 


    I found the following link: How to check the status of the database connection for Service Desk? and it fails, the reason was the password configured for the "sa" and "mdbadmin" accounts. Both of them had some special characters and I think it makes it too complex to use in SDM configuration.


    My recommendation to everybody is to avoid using "<" "$" "\" in the password of this users (don't know which of them exactly was causing the issue).




  • 8.  Re: CA SDM Installation Error

    Posted Jan 23, 2017 10:07 AM

    HI InfiniteLoop ,


      Thank you for your feedback.



  • 9.  Re: CA SDM Installation Error

    Posted Jan 23, 2017 02:37 AM

    Hey InfiniteLoop


    Great to hear that you got your problem resolved by changing the sa and mdbadmin password.