CA Service Management

Expand all | Collapse all

Asset import data greater length than destination field

Jump to Best Answer
  • 1.  Asset import data greater length than destination field

    Posted 11-05-2015 06:24 AM

    Hi Team,

    I am importing huge amount of asset data but there are some field which are showing error as the length of some source field data is greater than the destination field max size.As for example, PO Number in source csv is more than 20 characters but the maximum acceptable value in destination field is 20. So its showing error:- Web Service threw exception CA.Common.Utilities.Exceptions.ValidationException: 1. The Purchase Order ID contains data with an invalid type or size. The expected data type (size) is string(20), and the actual data is ***********

    at CA.Applications.Business.Asset.Save()

    at WebService.Service.SaveWithNormalization(Byte[] RequestStream)


    For some other fields ,I am facing the same issue as for example for Room Location.It takes max 30 string but the data we have in this field is greater than 30 character. I can not change these values as these are customer provided and they dont want to change these values as well. So how can I resolve this issue?


    Someone please help me to get it resolved.


    Thanks

    Manirul



  • 2.  Re: Asset import data greater length than destination field

    Posted 11-05-2015 07:41 AM

    Hi Manirul,

     

    the only possibility is to enlarge the affected fields manualy. Here an example:

    the extension sch, for example customername.sch I defined the size of  user_smag as STRING 1000 instead of STRING 200 (default)

    ////////////////////////////////////////////////////////////////////////////

    TABLE Attached_Events

    ////////////////////////////////////////////////////////////////////////////

    {

      user_smag             STRING 1000 ;                           //  200 -> 1000

    }

     

    This will work, if the  definition of the colomn in the database allows more than 200 characters. If not you have to change the size of the column directly in the database. as well.

     

    Regards

       Baerbel



  • 3.  Re: Asset import data greater length than destination field

    Posted 11-05-2015 08:49 AM

    Hi Baerbel,

    I can understand your point,but I did not get where exactly I need to change. As for example, I have a csv file with customer data like Asset Name,Serial No,Room Location,PO etc. I have imported this csv through Data Importer of ITAM 14.1 and mapped these source fields with destination fields of ITAM. If you kindly clarify a bit how can I change the affected fields manually I mean where exactly I should change,it will be very much helpful.

     

    Thanks

    Manirul



  • 4.  Re: Asset import data greater length than destination field

    Posted 11-05-2015 10:22 AM

    Hi Manirul,

     

    my suggestion can be used in a SDM environment, not in an ITAM environment. Do you need a solution for ITAM, I'm sorry but I cannot help.

    Regards

        Baerbel



  • 5.  Re: Asset import data greater length than destination field

    Posted 11-05-2015 10:34 AM

    Thanks Baerbal.Yes, I need this solution for ITAM 14.1

    Anyone please help me, I am stuck here.

     

    Thanks in advance

    Manirul



  • 6.  Re: Asset import data greater length than destination field

    Broadcom Employee
    Posted 11-05-2015 12:56 PM

    Manirul,

     

    I do not believe it is possible to increase the field size for default fields in Itam 14.1. I will try to get more information on that.

    If data does not yet exist, you can create extended fields and enter a custom field size for data that may exceed the default.

     

    Thank you,

    Doug



  • 7.  Re: Asset import data greater length than destination field

    Posted 11-05-2015 01:56 PM

    Thanks Doug. Actually some data are already using the default one so cant create extended fields.

     

    Should I change in database level or it can be done in other way that I need to know. If anyone got any other ideas, please share with me.

     

     

    Thanks

    Manirul



  • 8.  Re: Asset import data greater length than destination field

    Posted 11-06-2015 10:06 AM

    Hi Manirul,

     

    In the ITAM Application the field size cannot be changed; rather the only option would be to delete and re-create the field with a different naming convention.

    Example: Purchase Order ID you could use Purchase Order-ID or Purchase Order ID-

     

    Regards,

    Carol Uranker



  • 9.  Re: Asset import data greater length than destination field

    Posted 11-06-2015 11:44 AM

    Hi Carol,

    Isn't it possible even if we change the max size in ca_owned_resource table,just keen to know. The reason I am asking is half of the assets are already uploaded without any issues and using these PO and Room Location field. So I cant delete these fields right now as these fields are being used. Any solution on this Carol?

     

     

    Thanks

    Manirul



  • 10.  Re: Asset import data greater length than destination field
    Best Answer

    Posted 11-09-2015 01:25 PM

    Hello Manirul,

     

    It is not possible to change the field size of any of our out of the box fields.

     

    As Carol mentioned, create a new extended field with a different name from the OOTB field named Purchase Order, and give it a longer field length.

     

    Next, create a data import file (csv) containing columns like asset model name, asset serial number, original purchase order id field, new purchase order id field, and any other fields needed for an asset import.

     

    To create the data import file, create a new asset search that finds assets where the original purchase order id field 'has any value'. 

    Add the fields needed to this search, and then export this to a CSV file.

     

    Then create a data import that updates the NEW purchase order ID field with the OLD purchase order id field data - and use the CSV as the data file.

     

    Lastly, change the asset configuration to HIDE the original purchase order ID field, and show ONLY the new purchase order ID field.

     

    Hope this helps,

    Gale Bacon

    CA Technologies



  • 11.  Re: Asset import data greater length than destination field

    Posted 11-11-2015 09:15 AM

    Manirul,

     

    I believe this would make an excellent enhancement request.  The ability to extend field sizes without having to go thru the delete, recreate and hide process would surely make the application more user friendly.

     

     

    The application may not be able to accommodate this enhancement for all fields as the mdb is highly relational.  However,  I believe you should be able to present a good business case to justify this enhancement for fields such as  PO and Room Location.



  • 12.  Re: Asset import data greater length than destination field

    Posted 11-11-2015 01:13 PM

    I would vote this as an Enhancement; it would greatly improve customer usage.



  • 13.  Re: Asset import data greater length than destination field

    Posted 11-12-2015 02:21 PM

    Manirul,

     

    Here are the  instructions to create an enhancement request (idea).

    Click on the communities link, then search for 'CA Service Management' and click the link to enter that forum.

    Once on the main 'CA Service Management' community page, click 'Content'.

    In the left menu, several product categories are listed, like CABI, CA CMDB, IT Asset Manager, etc.

    Select ‘IT Asset Manager’.  Then select the ‘Ideas’ link to see previously submitted enhancements from other IT Asset Manager users.

    You will see the ideas marked with a status of  'under review', 'delivered', etc.

    On the left you'll see a 'create an idea' link where you can then enter your own enhancement idea.”

     

    Once you create the enhancement, I am sure others will vote it up. 



  • 14.  Re: Asset import data greater length than destination field

    Broadcom Employee
    Posted 11-13-2015 05:11 AM

    Hi Manirul,

     

    I have marked Gale's response as correct and would advise you to follow Debbie's suggestion by posting an idea.

     

    Thanks,

    Alex