CA Service Management

Expand all | Collapse all

SDM 14.1 PDM_LDAP_IMPORT error

Jump to Best Answer
  • 1.  SDM 14.1 PDM_LDAP_IMPORT error

    Posted 08-12-2015 01:05 AM

    Hi all,

     

    I am trying to import from AD by using PDM_LDAP_IMPORT, however it returns an error message "Method got_dob in Ldap_Catcher failed (NOT FOUND)"

    STDLOG shows "web:local      13064 ERROR      parse.c      8051 Unable to fetch DOB for PDM_LIST at lsEnd.mac[28]: NOT FOUND"

    I tried PDM_LDAP_TEST, and it was able to read the info.

    Does anyone have anyone why is this happening? Thanks in advance.

     

    ----------

    Edit. I run into this issue again with CA SDM 14.1, this time the work around provided by Lila does not work.

    Any one has experience with this issue on 14.1.02?

     

    Best regards,

    Conan



  • 2.  Re: PDM_LDAP_IMPORT error

    Posted 08-12-2015 01:38 AM

    Hi Conan,

     

    Whats the version of SDM and its patch level? It worked fine earlier or never worked? Did you add any to the custom ldap.mod file?  If yes, remove the file from site/mods/majic folder and then try to import the contacts to see if it works.

     

    Thanks,

    Naveen



  • 3.  Re: PDM_LDAP_IMPORT error

    Posted 08-12-2015 02:24 AM

    Hi Naveen,

     

    It is 12.9 SDM version dtn-416, with Cumulative Patch #1.

    It never worked since install and there is no custom ldap.mod file.

     

    Best regards,

    Conan



  • 4.  Re: PDM_LDAP_IMPORT error

    Posted 08-12-2015 09:31 AM

    Can you verify if CUM#1 was corretly applied? If applied correctly then 3 patches should comprise it.



  • 5.  Re: PDM_LDAP_IMPORT error
    Best Answer

    Broadcom Employee
    Posted 08-12-2015 10:00 AM

    Hi Conan

    I had a similar issue in the past, in that case:

     

    Definition:        DEC 11 2014    11:03Tech: LILA VALLE

    When i try create user from LDAP like:

    File --> New Contact from LDAP  --> Click on Search buttonI dont see no one user in list, but in count (bottom right corner) i see:

    1-17 of 17.

    In stdlog:

    Unable to fetch DOB for PDM_LIST at lsEnd.mac[28]

     

    Resolution:       

       

    Problem is due the ldap_search_base defined as

      DC=mydomain, DC=local

    the space  after the comma cause this issue,

    after change to:

      DC=mydomain,DC=local

    problem is fixed.

     

     

    I hope it helps ...

    Regards, Lila



  • 6.  Re: PDM_LDAP_IMPORT error

    Posted 08-12-2015 12:12 PM

    Thinking about problem num #2970 by looking at the error "Method got_dob in Ldap_Catcher failed (NOT FOUND)".

     

    Thanks,

    Naveen



  • 7.  Re: PDM_LDAP_IMPORT error

    Posted 08-13-2015 10:43 PM

    Hi Lila,

     

    Thanks a lot for your help. Your solution works like a charm.

     

    Best regards,

    Conan



  • 8.  Re: PDM_LDAP_IMPORT error

    Broadcom Employee
    Posted 09-02-2015 04:39 AM

    Excellent!  I just came across this issue with SDM 14.1 at a client site.  Had me quite puzzled but this solution hit the spot.



  • 9.  Re: PDM_LDAP_IMPORT error

    Posted 02-26-2016 02:54 AM

    Hi James,

     

    I run into this issue again with 14.1, I created this post when I was working with 12.9.

    Just wondering did this work around fix the issue?

    And did your environment apply any cum patch?

    Because it seem this work around no longer work with 14.1.

     

    Best regards,

    Conan



  • 10.  Re: SDM 14.1 PDM_LDAP_IMPORT error

    Posted 10-25-2016 03:09 PM

    ConanLam

     

    I am having the same issue with SDM 14.1.03 and there is no space in the ldap_search_base.  Did you resolve this?

     

    thanks,

     

    J.W.



  • 11.  Re: SDM 14.1 PDM_LDAP_IMPORT error

    Posted 11-23-2018 02:16 AM

    I had same problem in 17.1.0.1. (fresh migrate from 12.5)

    This idea resolved!

    Thanks

     

    Gábor